aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/pxcab/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-07-16 10:19:13 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-07-16 10:19:13 +0000
commitf49a6c5859bcfcbe59fb8c125d6fdcbbcb3360ed (patch)
treeda320bef34fb95f56667a13fd6a6a7c648edc338 /target/linux/pxcab/image
parent515df8d0dd2d48d316681f7aad99694e783b64c8 (diff)
downloadmaster-187ad058-f49a6c5859bcfcbe59fb8c125d6fdcbbcb3360ed.tar.gz
master-187ad058-f49a6c5859bcfcbe59fb8c125d6fdcbbcb3360ed.tar.bz2
master-187ad058-f49a6c5859bcfcbe59fb8c125d6fdcbbcb3360ed.zip
This patch adds a target for the IBM PowerXCell Accelerator Board.
(aka mvXCell-8i from MatrixVision or GigaAccel 180 from Fixstars) http://us.fixstars.com/products/gigaaccel/ This build will create zImage suitable for TFTP boot image. * v2 - add axonram device driver - switch to 2.6.30.1 Signed-off-by: Akinobu Mita <mita@fixstars.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16860 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/pxcab/image')
-rw-r--r--target/linux/pxcab/image/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/pxcab/image/Makefile b/target/linux/pxcab/image/Makefile
new file mode 100644
index 0000000000..ae551fa961
--- /dev/null
+++ b/target/linux/pxcab/image/Makefile
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+ cp $(LINUX_DIR)/arch/powerpc/boot/zImage $(KDIR)/zImage
+endef
+
+define Image/BuildKernel
+ mkdir -p $(BIN_DIR)
+ cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+ cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+$(eval $(call BuildImage))