aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ps3/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:41 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-10-23 06:23:41 +0000
commit2e70752ffa98e97c307b024a944fe618db9f9ffc (patch)
tree86e85e9d03bccd8f206f27f453f55f17dadb5c17 /target/linux/ps3/Makefile
parent3aade25a90245511c0b5f0ad7278a1977e248a4c (diff)
downloadmaster-187ad058-2e70752ffa98e97c307b024a944fe618db9f9ffc.tar.gz
master-187ad058-2e70752ffa98e97c307b024a944fe618db9f9ffc.tar.bz2
master-187ad058-2e70752ffa98e97c307b024a944fe618db9f9ffc.zip
Add ps3 target
This patch adds a target for the Sony PlayStation 3. Signed-off-by: Jeremy Kerr <jk@ozlabs.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9413 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ps3/Makefile')
-rw-r--r--target/linux/ps3/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/ps3/Makefile b/target/linux/ps3/Makefile
new file mode 100644
index 0000000000..3499d024bd
--- /dev/null
+++ b/target/linux/ps3/Makefile
@@ -0,0 +1,34 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=ps3
+BOARDNAME:=Sony PlayStation 3
+LINUX_VERSION:=2.6.23
+KERNEL_CC:=
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build bootloader images for the Playstation 3
+endef
+
+# no patches required
+define Kernel/Prepare/ps3
+ bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
+endef
+
+define Kernel/Prepare
+ $(call Kernel/Prepare/ps3)
+endef
+
+# include the profiles
+#-include profiles/*.mk
+
+KERNELNAME:="zImage"
+$(eval $(call BuildTarget))