aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-05 13:55:52 +0000
commit9958378c233871745b6042df411f7ea8b3fa6d28 (patch)
tree249776c430feb12ac575182a62b558e500f652c4 /target/linux/ppc44x
parent7fef288830cda93409865932782ce493b56a4d69 (diff)
downloadmaster-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.tar.gz
master-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.tar.bz2
master-187ad058-9958378c233871745b6042df411f7ea8b3fa6d28.zip
image: fix jffs2(_nand) image generation
Variables dependend on JFFS2_BLOCKSIZE and NANDBLOCK_SIZE are used for template generation, so need to be present before inclusion of image.mk in target image Makefiles. So move all declarations to before any includes. Fixes: r42878 ("image.mk: clean up and parallelize mkfs calls") Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46564 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc44x')
-rw-r--r--target/linux/ppc44x/image/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/ppc44x/image/Makefile b/target/linux/ppc44x/image/Makefile
index b0513af788..e2303f6e78 100644
--- a/target/linux/ppc44x/image/Makefile
+++ b/target/linux/ppc44x/image/Makefile
@@ -4,10 +4,12 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
+JFFS2_BLOCKSIZE=256k
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-JFFS2_BLOCKSIZE=256k
define Image/Prepare
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(DTS_DIR)/canyonlands.dts > $(KDIR)/openwrt-canyonlands.dtb