aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc44x/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2009-01-30 11:38:46 +0000
committerImre Kaloz <kaloz@openwrt.org>2009-01-30 11:38:46 +0000
commitf9d0eaf8a3f42c95d03112eb9e6a0ae8b5a2553d (patch)
tree916d67d3cbfab34ad6bfd7973643419567b2df36 /target/linux/ppc44x/image/Makefile
parent5f0a8f07f2595075a89976a3deb04872e159717f (diff)
downloadmaster-187ad058-f9d0eaf8a3f42c95d03112eb9e6a0ae8b5a2553d.tar.gz
master-187ad058-f9d0eaf8a3f42c95d03112eb9e6a0ae8b5a2553d.tar.bz2
master-187ad058-f9d0eaf8a3f42c95d03112eb9e6a0ae8b5a2553d.zip
upgrade ppc44x to 2.6.28.2, add basic support for the AMCC Canyonlands
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14280 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc44x/image/Makefile')
-rw-r--r--target/linux/ppc44x/image/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/target/linux/ppc44x/image/Makefile b/target/linux/ppc44x/image/Makefile
index 5c1d023cb0..b8d5e95109 100644
--- a/target/linux/ppc44x/image/Makefile
+++ b/target/linux/ppc44x/image/Makefile
@@ -1,5 +1,5 @@
-#
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -11,6 +11,7 @@ JFFS2_BLOCKSIZE=256k
define Image/Prepare
cp $(LINUX_DIR)/arch/powerpc/boot/cuImage.taishan $(KDIR)/uImage
+ dtc -O dtb -R 4 -S 0x20000 $(LINUX_DIR)/arch/powerpc/boot/dts/canyonlands.dts > $(KDIR)/openwrt-canyonlands.dtb
endef
define Image/BuildKernel
@@ -33,7 +34,12 @@ define Image/Build/squashfs
( \
dd if=$(KDIR)/uImage bs=2048k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-taishan-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
+ dd if=$(KDIR)/openwrt-canyonlands.dtb bs=128k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-canyonlands-$(1).img
endef
$(eval $(call BuildImage))