aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-07-19 07:38:06 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-07-19 07:38:06 +0000
commit204dcb23c539e92d7931e59a2dab770f844ca3bb (patch)
tree53796bd72212230855d3d3c75fa09dcaa6e4cdae /target/linux/ppc40x/image
parentd13d6cb744aba97f4744f097e7c6e12865d6f5d7 (diff)
downloadmaster-187ad058-204dcb23c539e92d7931e59a2dab770f844ca3bb.tar.gz
master-187ad058-204dcb23c539e92d7931e59a2dab770f844ca3bb.tar.bz2
master-187ad058-204dcb23c539e92d7931e59a2dab770f844ca3bb.zip
[ppc40x] add support for the OpenRB Light board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16908 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index a5be9be92a..60d85bffdd 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -39,6 +39,10 @@ define Image/Build/jffs2-64k
dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-jffs2.img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-light bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-light-jffs2.img
endef
define Image/Build/squashfs
@@ -56,6 +60,10 @@ define Image/Build/squashfs
dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1152k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.openrb-light bs=1152k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-openrb-light-$(1).img
endef
$(eval $(call BuildImage))