aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-11-26 10:06:34 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-11-26 10:06:34 +0000
commit0eb1e059baaaa3054e38ba046c50f702e246053e (patch)
tree8d27069f3352e5274a253fafb87812df4d1e3d3e /target/linux/ppc40x/image
parent38b1737377cefbde769259b62414cc2c820ee7c8 (diff)
downloadmaster-187ad058-0eb1e059baaaa3054e38ba046c50f702e246053e.tar.gz
master-187ad058-0eb1e059baaaa3054e38ba046c50f702e246053e.tar.bz2
master-187ad058-0eb1e059baaaa3054e38ba046c50f702e246053e.zip
nuke the magicbox target and incorporate a rewritten port into ppc40x - note: no CF driver for now
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13358 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc40x/image')
-rw-r--r--target/linux/ppc40x/image/Makefile20
1 files changed, 18 insertions, 2 deletions
diff --git a/target/linux/ppc40x/image/Makefile b/target/linux/ppc40x/image/Makefile
index ce3f136583..b54cc06488 100644
--- a/target/linux/ppc40x/image/Makefile
+++ b/target/linux/ppc40x/image/Makefile
@@ -27,7 +27,15 @@ define Image/Build/jffs2-128k
dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-jffs2.img
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-jffs2.img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv1-jffs2.img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-jffs2.img
endef
define Image/Build/squashfs
@@ -36,7 +44,15 @@ define Image/Build/squashfs
dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
dd if=$(KDIR)/openwrt-kilauea.dtb bs=128k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-kilauea-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv1 bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv1-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/cuImage.magicboxv2 bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=64k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-magicboxv2-$(1).img
endef
$(eval $(call BuildImage))