aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ppc40x/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-01-29 00:58:46 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-01-29 00:58:46 +0000
commitedcfc293f777b93a918f78d29cec03710cf1843e (patch)
treee949944335e0e9fccc1fbfb3a571a96ef6e683c4 /target/linux/ppc40x/Makefile
parentba24df156d9db69360e4dc9bb6e43793ecf06a96 (diff)
downloadmaster-187ad058-edcfc293f777b93a918f78d29cec03710cf1843e.tar.gz
master-187ad058-edcfc293f777b93a918f78d29cec03710cf1843e.tar.bz2
master-187ad058-edcfc293f777b93a918f78d29cec03710cf1843e.zip
add basic support for the AMCC PPC405EX Kilauea evaluation board
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10303 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ppc40x/Makefile')
-rw-r--r--target/linux/ppc40x/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/target/linux/ppc40x/Makefile b/target/linux/ppc40x/Makefile
new file mode 100644
index 0000000000..cd64ea3f65
--- /dev/null
+++ b/target/linux/ppc40x/Makefile
@@ -0,0 +1,23 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=powerpc
+BOARD:=ppc40x
+BOARDNAME:=AMCC Kilauea
+FEATURES:=squashfs
+
+LINUX_VERSION:=2.6.24
+LINUX_KARCH:=powerpc
+
+include $(INCLUDE_DIR)/target.mk
+
+define Target/Description
+ Build firmware images for the AMCC Kilauea evaluation board
+endef
+
+$(eval $(call BuildTarget))