aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2016-04-19 20:14:31 +0000
committerHauke Mehrtens <hauke@openwrt.org>2016-04-19 20:14:31 +0000
commit903655e5b17de41acc28499ec0c8e691f4dd8a00 (patch)
tree6fa6a4382fcabba8f4fde02e47dcf656a92a8266 /target/linux/oxnas
parente345dfc179fcd931370d3ca0f6df194450746e2d (diff)
downloadmaster-187ad058-903655e5b17de41acc28499ec0c8e691f4dd8a00.tar.gz
master-187ad058-903655e5b17de41acc28499ec0c8e691f4dd8a00.tar.bz2
master-187ad058-903655e5b17de41acc28499ec0c8e691f4dd8a00.zip
oxnas: clean-up and improve profiles
Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@49198 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/profiles/00-default.mk9
-rw-r--r--target/linux/oxnas/profiles/cloudengines.mk (renamed from target/linux/oxnas/profiles/pogoplug.mk)8
2 files changed, 10 insertions, 7 deletions
diff --git a/target/linux/oxnas/profiles/00-default.mk b/target/linux/oxnas/profiles/00-default.mk
index fb04ba788c..67f866ee80 100644
--- a/target/linux/oxnas/profiles/00-default.mk
+++ b/target/linux/oxnas/profiles/00-default.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2011 OpenWrt.org
+# Copyright (C) 2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,11 +8,14 @@
define Profile/Default
NAME:=Default Profile
PACKAGES:=\
- kmod-usb-core kmod-usb3 \
- kmod-ledtrig-usbdev
+ kmod-usb-core kmod-usb3 kmod-ledtrig-usbdev \
+ kmod-usb-storage \
+ kmod-i2c-gpio kmod-rtc-pcf8563 kmod-rtc-ds1307 \
+ kmod-gpio-beeper kmod-hwmon-core kmod-hwmon-gpiofan
endef
define Profile/Default/Description
Default package set compatible with most boards.
endef
+
$(eval $(call Profile,Default))
diff --git a/target/linux/oxnas/profiles/pogoplug.mk b/target/linux/oxnas/profiles/cloudengines.mk
index dcab128ef1..ed0a235254 100644
--- a/target/linux/oxnas/profiles/pogoplug.mk
+++ b/target/linux/oxnas/profiles/cloudengines.mk
@@ -5,20 +5,20 @@
#
define Profile/POGOPLUG_PRO
- NAME:=PogoPlug Pro
+ NAME:=Cloud Engines Pogoplug Pro
endef
define Profile/POGOPLUG_PRO/Description
- Profile with built-in ox820 PogoPlug Pro device-tree
+ Profile with built-in ox820 Pogoplug Pro device-tree
(board with miniPCIe slot)
endef
define Profile/POGOPLUG_V3
- NAME:=PogoPlug V3
+ NAME:=Cloud Engines Pogoplug V3
endef
define Profile/POGOPLUG_V3/Description
- Profile with built-in ox820 PogoPlug V3 device-tree
+ Profile with built-in ox820 Pogoplug V3 device-tree
(board without miniPCIe slot)
endef