aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2016-06-23 13:41:20 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-23 13:41:20 +0200
commit5fdc19893e17ef93dd1f8c08e240f6dc3bbd5186 (patch)
tree03c491fea3d0079cdeb71f54dfec30792ce41b1c /target/linux/oxnas
parentd22dcaa69134a7148139ab7ae82608fbe319cd01 (diff)
downloadmaster-187ad058-5fdc19893e17ef93dd1f8c08e240f6dc3bbd5186.tar.gz
master-187ad058-5fdc19893e17ef93dd1f8c08e240f6dc3bbd5186.tar.bz2
master-187ad058-5fdc19893e17ef93dd1f8c08e240f6dc3bbd5186.zip
oxnas: move target-specific modules into target's modules.mk
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target/linux/oxnas')
-rw-r--r--target/linux/oxnas/modules.mk41
1 files changed, 41 insertions, 0 deletions
diff --git a/target/linux/oxnas/modules.mk b/target/linux/oxnas/modules.mk
new file mode 100644
index 0000000000..7016398619
--- /dev/null
+++ b/target/linux/oxnas/modules.mk
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2006-2014 OpenWrt.org
+# Copyright (C) 2016 LEDE project
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/ata-oxnas-sata
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=oxnas Serial ATA support
+ KCONFIG:=CONFIG_SATA_OXNAS
+ DEPENDS:=@TARGET_oxnas
+ FILES:=$(LINUX_DIR)/drivers/ata/sata_oxnas.ko
+ AUTOLOAD:=$(call AutoLoad,41,sata_oxnas,1)
+ $(call AddDepends/ata)
+endef
+
+define KernelPackage/ata-oxnas-sata/description
+ SATA support for OX934 core found in the OX82x/PLX782x SoCs
+endef
+
+$(eval $(call KernelPackage,ata-oxnas-sata))
+
+
+define KernelPackage/usb2-oxnas
+ SUBMENU:=$(BLOCK_MENU)
+ TITLE:=OXNAS USB controller driver
+ DEPENDS:=@TARGET_oxnas +kmod-usb2
+ KCONFIG:=CONFIG_USB_EHCI_OXNAS
+ FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-oxnas.ko
+ AUTOLOAD:=$(call AutoLoad,55,ehci-oxnas,1)
+ $(call AddDepends/usb)
+endef
+
+define KernelPackage/usb2-oxnas/description
+ This driver provides USB Device Controller support for the
+ EHCI USB host built-in to the PLXTECH NAS782x SoC
+endef
+
+$(eval $(call KernelPackage,usb2-oxnas))