aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-05 00:20:41 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-05 00:20:41 +0000
commit64a0deb752d07d1d2a8766055886c921c0101deb (patch)
treefab9b2a49124dffa674de949887efb6e7ad34908 /target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch
parentb7bce4449ef4916dd27140b8bcf60fdf31140439 (diff)
downloadmaster-187ad058-64a0deb752d07d1d2a8766055886c921c0101deb.tar.gz
master-187ad058-64a0deb752d07d1d2a8766055886c921c0101deb.tar.bz2
master-187ad058-64a0deb752d07d1d2a8766055886c921c0101deb.zip
oxnas: re-add support for kernel 3.14
This reverts commit c81ddddde5fd193802d511b42eb7b108aac17136 on https://gitorious.org/openwrt-oxnas/openwrt-oxnas.git which removed patches and config for 3.14. [arm_introduce-dma-fiq-irq-broadcast patch was renamed to match 3.18] Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43520 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch')
-rw-r--r--target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch b/target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch
new file mode 100644
index 0000000000..1eb74debcf
--- /dev/null
+++ b/target/linux/oxnas/patches-3.14/310-oxnas-clocksource.patch
@@ -0,0 +1,24 @@
+Index: linux-3.14.18/drivers/clocksource/Kconfig
+===================================================================
+--- linux-3.14.18.orig/drivers/clocksource/Kconfig
++++ linux-3.14.18/drivers/clocksource/Kconfig
+@@ -140,3 +140,9 @@ config VF_PIT_TIMER
+ bool
+ help
+ Support for Period Interrupt Timer on Freescale Vybrid Family SoCs.
++
++config CLKSRC_RPS_TIMER
++ def_bool y if ARCH_OXNAS
++ select CLKSRC_MMIO
++ help
++ This option enables support for the oxnas rps timers.
+Index: linux-3.14.18/drivers/clocksource/Makefile
+===================================================================
+--- linux-3.14.18.orig/drivers/clocksource/Makefile
++++ linux-3.14.18/drivers/clocksource/Makefile
+@@ -37,3 +37,5 @@ obj-$(CONFIG_ARM_ARCH_TIMER) += arm_arc
+ obj-$(CONFIG_ARM_GLOBAL_TIMER) += arm_global_timer.o
+ obj-$(CONFIG_CLKSRC_METAG_GENERIC) += metag_generic.o
+ obj-$(CONFIG_ARCH_HAS_TICK_BROADCAST) += dummy_timer.o
++
++obj-$(CONFIG_CLKSRC_RPS_TIMER) += oxnas_rps_timer.o