aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/oxnas/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-11-26 09:00:08 +0000
committerJohn Crispin <blogic@openwrt.org>2014-11-26 09:00:08 +0000
commit7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9 (patch)
tree24af078d708bfb6b3027ff4064114d439e4213e1 /target/linux/oxnas/Makefile
parent2088d1ea438e14be13e9d579ebf847f9cc50245d (diff)
downloadmaster-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.tar.gz
master-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.tar.bz2
master-187ad058-7d4dfd7dd7ce1ac02d84ad7482e3f7d168d61ec9.zip
add new target 'oxnas'
This is the oxnas target previously developed at http://gitorious.org/openwrt-oxnas Basically, this consolidates the changes and addtionas from http://github.org/kref/linux-oxnas into a new OpenWrt hardware target 'oxnas' adding support for PLX Technology NAS7820/NAS7821/NAS7825/... formally known as Oxford Semiconductor OXE810SE/OXE815/OX820/... For now there are 4 supported boards: Cloud Engines Pogoplug V3 (without PCIe) fully supported Cloud Engines Pogoplug Pro (with PCIe) fully supported MitraStar STG-212 aka ZyXEL NSA-212, aka Medion Akoya P89625 / P89636 / P89626 / P89630, aka Medion MD 86407 / MD 86805 / MD 86517 / MD 86587 fully supported, see http://wiki.openwrt.org/toh/medion/md86587 Shuttle KD-20 partially supported (S-ATA driver lacks support for 2nd port) Signed-off-by: Daniel Golle <daniel@makrotopia.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43388 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/oxnas/Makefile')
-rw-r--r--target/linux/oxnas/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/target/linux/oxnas/Makefile b/target/linux/oxnas/Makefile
new file mode 100644
index 0000000000..67d45bc4f6
--- /dev/null
+++ b/target/linux/oxnas/Makefile
@@ -0,0 +1,28 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=oxnas
+BOARDNAME:=PLXTECH NAS782X
+DEVICE_TYPE:=nas
+FEATURES:=gpio nand pcie usb usbgadget ramdisk rtc squashfs
+CPU_TYPE:=mpcore
+
+MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
+
+KERNEL_PATCHVER:=3.18
+
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += \
+ kmod-button-hotplug kmod-input-gpio-keys-polled kmod-leds-gpio \
+ kmod-i2c-gpio uboot-envtools uboot-oxnas-ox820
+
+KERNELNAME:=zImage dtbs
+
+$(eval $(call BuildTarget))