aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2013-06-05 06:17:12 +0000
committerImre Kaloz <kaloz@openwrt.org>2013-06-05 06:17:12 +0000
commit31eaa46c9b7b8d9a2a3f4e3a2f148763dfed1879 (patch)
treeb0bbf1cd41a8b85dc0fd2d77653e9c78657c9a02 /target/linux/orion
parent4df0b1706c8e4958a9c82179923b3f48d2f8fd96 (diff)
downloadmaster-187ad058-31eaa46c9b7b8d9a2a3f4e3a2f148763dfed1879.tar.gz
master-187ad058-31eaa46c9b7b8d9a2a3f4e3a2f148763dfed1879.tar.bz2
master-187ad058-31eaa46c9b7b8d9a2a3f4e3a2f148763dfed1879.zip
[orion]: only copy uImages to the bin dir on ramdisk builds
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36851 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/orion')
-rw-r--r--target/linux/orion/image/generic.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/orion/image/generic.mk b/target/linux/orion/image/generic.mk
index c3aa50f01c..19daaf647a 100644
--- a/target/linux/orion/image/generic.mk
+++ b/target/linux/orion/image/generic.mk
@@ -82,7 +82,9 @@ define Image/BuildKernel/ARM/uImage
'$(STAGING_DIR_HOST)/bin/mkimage' -A arm -O linux -T kernel \
-C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
-d '$(KDIR)/$(1)-zImage' '$(KDIR)/$(1)-uImage'
+ ifeq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y) # only copy uImage for ramdisk build
cp '$(KDIR)/$(1)-uImage' '$(BIN_DIR)/openwrt-$(1)-uImage'
+ endif
endef
define Image/BuildKernel/JFFS2uImage