aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/patches
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2010-06-06 10:51:52 +0000
committerHauke Mehrtens <hauke@openwrt.org>2010-06-06 10:51:52 +0000
commit9d9eb999e17f98809f2e698f01fa2acff87f83b0 (patch)
treecf19645de2e65983f53a1a959c8de8d43955763c /target/linux/orion/patches
parente69562eb2892d3be7397a002fdbb74d71e66c673 (diff)
downloadmaster-187ad058-9d9eb999e17f98809f2e698f01fa2acff87f83b0.tar.gz
master-187ad058-9d9eb999e17f98809f2e698f01fa2acff87f83b0.tar.bz2
master-187ad058-9d9eb999e17f98809f2e698f01fa2acff87f83b0.zip
orion: Update Orion in trunk to kernel 2.6.34.
Was flashed on WRT350Nv2, booted and is running for several days. Closes #7405 Thank you maddes for your patch. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21682 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/orion/patches')
-rw-r--r--target/linux/orion/patches/010-ignore_atag_cmdline.patch2
-rw-r--r--target/linux/orion/patches/090-wrt350nv2_gpio_leds_buttons.patch102
-rw-r--r--target/linux/orion/patches/200-dt2_board_support.patch2
-rw-r--r--target/linux/orion/patches/300-skb_cb_align.patch11
4 files changed, 2 insertions, 115 deletions
diff --git a/target/linux/orion/patches/010-ignore_atag_cmdline.patch b/target/linux/orion/patches/010-ignore_atag_cmdline.patch
index 9df21f1eb5..08a6b1fdac 100644
--- a/target/linux/orion/patches/010-ignore_atag_cmdline.patch
+++ b/target/linux/orion/patches/010-ignore_atag_cmdline.patch
@@ -1,6 +1,6 @@
--- a/arch/arm/kernel/setup.c
+++ b/arch/arm/kernel/setup.c
-@@ -629,7 +629,7 @@ __tagtable(ATAG_REVISION, parse_tag_revi
+@@ -595,7 +595,7 @@ __tagtable(ATAG_REVISION, parse_tag_revi
static int __init parse_tag_cmdline(const struct tag *tag)
{
diff --git a/target/linux/orion/patches/090-wrt350nv2_gpio_leds_buttons.patch b/target/linux/orion/patches/090-wrt350nv2_gpio_leds_buttons.patch
deleted file mode 100644
index 30f75fc8af..0000000000
--- a/target/linux/orion/patches/090-wrt350nv2_gpio_leds_buttons.patch
+++ /dev/null
@@ -1,102 +0,0 @@
---- a/arch/arm/mach-orion5x/wrt350n-v2-setup.c
-+++ b/arch/arm/mach-orion5x/wrt350n-v2-setup.c
-@@ -15,6 +15,9 @@
- #include <linux/mtd/physmap.h>
- #include <linux/mv643xx_eth.h>
- #include <linux/ethtool.h>
-+#include <linux/leds.h>
-+#include <linux/gpio_keys.h>
-+#include <linux/input.h>
- #include <net/dsa.h>
- #include <asm/mach-types.h>
- #include <asm/gpio.h>
-@@ -24,6 +27,80 @@
- #include "common.h"
- #include "mpp.h"
-
-+/*
-+ * LEDs attached to GPIO
-+ */
-+static struct gpio_led wrt350n_v2_led_pins[] = {
-+ {
-+ .name = "wrt350nv2:green:power",
-+ .gpio = 0,
-+ .active_low = 1,
-+ }, {
-+ .name = "wrt350nv2:green:security",
-+ .gpio = 1,
-+ .active_low = 1,
-+ }, {
-+ .name = "wrt350nv2:orange:power",
-+ .gpio = 5,
-+ .active_low = 1,
-+ }, {
-+ .name = "wrt350nv2:green:usb",
-+ .gpio = 6,
-+ .active_low = 1,
-+ }, {
-+ .name = "wrt350nv2:green:wireless",
-+ .gpio = 7,
-+ .active_low = 1,
-+ },
-+};
-+
-+static struct gpio_led_platform_data wrt350n_v2_led_data = {
-+ .leds = wrt350n_v2_led_pins,
-+ .num_leds = ARRAY_SIZE(wrt350n_v2_led_pins),
-+};
-+
-+static struct platform_device wrt350n_v2_leds = {
-+ .name = "leds-gpio",
-+ .id = -1,
-+ .dev = {
-+ .platform_data = &wrt350n_v2_led_data,
-+ },
-+};
-+
-+/*
-+ * Buttons attached to GPIO
-+ */
-+static struct gpio_keys_button wrt350n_v2_buttons[] = {
-+ {
-+ .code = KEY_RESTART,
-+ .gpio = 3,
-+ .desc = "Reset Button",
-+ .active_low = 1,
-+ }, {
-+ .code = KEY_WLAN,
-+ .gpio = 2,
-+ .desc = "WPS Button",
-+ .active_low = 1,
-+ },
-+};
-+
-+static struct gpio_keys_platform_data wrt350n_v2_button_data = {
-+ .buttons = wrt350n_v2_buttons,
-+ .nbuttons = ARRAY_SIZE(wrt350n_v2_buttons),
-+};
-+
-+static struct platform_device wrt350n_v2_button_device = {
-+ .name = "gpio-keys",
-+ .id = -1,
-+ .num_resources = 0,
-+ .dev = {
-+ .platform_data = &wrt350n_v2_button_data,
-+ },
-+};
-+
-+/*
-+ * General setup
-+ */
- static struct orion5x_mpp_mode wrt350n_v2_mpp_modes[] __initdata = {
- { 0, MPP_GPIO }, /* Power LED green (0=on) */
- { 1, MPP_GPIO }, /* Security LED (0=on) */
-@@ -140,6 +217,8 @@ static void __init wrt350n_v2_init(void)
- orion5x_setup_dev_boot_win(WRT350N_V2_NOR_BOOT_BASE,
- WRT350N_V2_NOR_BOOT_SIZE);
- platform_device_register(&wrt350n_v2_nor_flash);
-+ platform_device_register(&wrt350n_v2_button_device);
-+ platform_device_register(&wrt350n_v2_leds);
- }
-
- static int __init wrt350n_v2_pci_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
diff --git a/target/linux/orion/patches/200-dt2_board_support.patch b/target/linux/orion/patches/200-dt2_board_support.patch
index 27154723e1..aa645ea499 100644
--- a/target/linux/orion/patches/200-dt2_board_support.patch
+++ b/target/linux/orion/patches/200-dt2_board_support.patch
@@ -16,7 +16,7 @@
select I2C_BOARDINFO
--- a/arch/arm/mach-orion5x/Makefile
+++ b/arch/arm/mach-orion5x/Makefile
-@@ -20,3 +20,4 @@ obj-$(CONFIG_MACH_WNR854T) += wnr854t-se
+@@ -21,3 +21,4 @@ obj-$(CONFIG_MACH_WNR854T) += wnr854t-se
obj-$(CONFIG_MACH_RD88F5181L_GE) += rd88f5181l-ge-setup.o
obj-$(CONFIG_MACH_RD88F5181L_FXO) += rd88f5181l-fxo-setup.o
obj-$(CONFIG_MACH_RD88F6183AP_GE) += rd88f6183ap-ge-setup.o
diff --git a/target/linux/orion/patches/300-skb_cb_align.patch b/target/linux/orion/patches/300-skb_cb_align.patch
deleted file mode 100644
index 3fefa4de39..0000000000
--- a/target/linux/orion/patches/300-skb_cb_align.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/include/linux/skbuff.h
-+++ b/include/linux/skbuff.h
-@@ -332,7 +332,7 @@ struct sk_buff {
- * want to keep them across layers you have to do a skb_clone()
- * first. This is owned by whoever has the skb queued ATM.
- */
-- char cb[48];
-+ char cb[48] __attribute__((aligned(8)));
- #if defined(CONFIG_IMQ) || defined(CONFIG_IMQ_MODULE)
- void *cb_next;
- #endif