aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2008-06-25 22:41:50 +0000
committerImre Kaloz <kaloz@openwrt.org>2008-06-25 22:41:50 +0000
commit0a0dbf04b5e01d72e2020d3678712f3415685c75 (patch)
tree5ceb88ea1275a8592696e3d4528849dc5bca4fd3 /target/linux/orion/image
parentfcbe8f3ffdc2b6d56706a3100ae869821c5575a1 (diff)
downloadmaster-187ad058-0a0dbf04b5e01d72e2020d3678712f3415685c75.tar.gz
master-187ad058-0a0dbf04b5e01d72e2020d3678712f3415685c75.tar.bz2
master-187ad058-0a0dbf04b5e01d72e2020d3678712f3415685c75.zip
generate orion images differently
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@11576 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/orion/image')
-rw-r--r--target/linux/orion/image/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index a8c2fbafff..862358253a 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -8,18 +8,17 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/Prepare
-#
-# XXX - FIXME, we hardcode for the WRT350N v2 for now
-#
- echo -en "\x61\x70\xa0\xe3\x06\x7c\x87\xe3" > $(KDIR)/zImage
- cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/zImage
+ cp $(LINUX_DIR)/arch/arm/boot/uImage $(KDIR)/uImage
endef
define Image/BuildKernel
+# WRT350N v2: mach id 1633 (0x661)
+ echo -en "\x06\x1c\xa0\xe3\x61\x10\x81\xe3" > $(KDIR)/wrt350nv2-zImage
+ cat $(LINUX_DIR)/arch/arm/boot/zImage >> $(KDIR)/wrt350nv2-zImage
$(STAGING_DIR_HOST)/bin/mkimage -A arm -O linux -T kernel \
-C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/zImage $(KDIR)/uImage
- cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-uImage
+ -d $(KDIR)/wrt350nv2-zImage $(KDIR)/wrt350nv2-uImage
+ cp $(KDIR)/wrt350nv2-uImage $(BIN_DIR)/openwrt-wrt350nv2-uImage
endef
define Image/Build