aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-07-21 02:30:46 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-07-21 02:30:46 +0000
commite5f75edc00943c15d16013fe41345436946e8ed0 (patch)
tree3c5d51bd5f7a15a8890dff0ae6fad89461bbcdd3 /target/linux/orion/image/Makefile
parent3adf17815c0b4bfe9cd0a4bd682eed46fd9d5127 (diff)
downloadmaster-187ad058-e5f75edc00943c15d16013fe41345436946e8ed0.tar.gz
master-187ad058-e5f75edc00943c15d16013fe41345436946e8ed0.tar.bz2
master-187ad058-e5f75edc00943c15d16013fe41345436946e8ed0.zip
orion: fix image build on non-linux systems
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16938 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/orion/image/Makefile')
-rw-r--r--target/linux/orion/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index 66edc04331..21d01a105a 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -57,7 +57,7 @@ define Image/Build/Freecom
$(CP) $(KDIR)/dt2-uImage $(TARGET_DIR)/boot/uImage
rm -rf $(TARGET_DIR)/{var,jffs,rom}
$(INSTALL_DIR) $(TARGET_DIR)/var
- $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --owner=root --group=root -C $(TARGET_DIR)/ .
+ $(TAR) cfj $(BIN_DIR)/openwrt-$(2)-$(1).img --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
$(STAGING_DIR_HOST)/bin/encode_crc $(BIN_DIR)/openwrt-$(2)-$(1).img $(BIN_DIR)/openwrt-$(2)-$(1)-webupgrade.img $(3)
endef