aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/orion/image/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commit9d42bb1a218d092b8c9447cf16ec2c94f7881c8d (patch)
tree422842a370190fdfcc59b10055cbbf761974bb76 /target/linux/orion/image/Makefile
parentdebf59c4e6f85df3132eae86b2e8c8399040c1ce (diff)
downloadmaster-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.tar.gz
master-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.tar.bz2
master-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20834 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/orion/image/Makefile')
-rw-r--r--target/linux/orion/image/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/orion/image/Makefile b/target/linux/orion/image/Makefile
index 81cd670120..180183bf67 100644
--- a/target/linux/orion/image/Makefile
+++ b/target/linux/orion/image/Makefile
@@ -4,7 +4,6 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
@@ -101,7 +100,7 @@ define Image/Build/squashfs
( \
dd if=$(KDIR)/uImage bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-$(1).img
+ ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
endef
$(eval $(call BuildImage))