aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap4/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2012-01-14 23:02:56 +0000
committerImre Kaloz <kaloz@openwrt.org>2012-01-14 23:02:56 +0000
commit8f76568da91dbe989e5365a4a6d3f50847b1c755 (patch)
treeafabe899aa387d9c1fd5509828b5ebe774a30bb7 /target/linux/omap4/Makefile
parent26cb77ef885e1858d0f7f06efa765e0d5d5de749 (diff)
downloadmaster-187ad058-8f76568da91dbe989e5365a4a6d3f50847b1c755.tar.gz
master-187ad058-8f76568da91dbe989e5365a4a6d3f50847b1c755.tar.bz2
master-187ad058-8f76568da91dbe989e5365a4a6d3f50847b1c755.zip
[target/omap4]: add support for OMAP4 based boards, starting with the PandaBoard
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29753 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap4/Makefile')
-rw-r--r--target/linux/omap4/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/target/linux/omap4/Makefile b/target/linux/omap4/Makefile
new file mode 100644
index 0000000000..24fb34420d
--- /dev/null
+++ b/target/linux/omap4/Makefile
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=omap4
+BOARDNAME:=TI OMAP4
+FEATURES:=usb targz
+
+LINUX_VERSION:=3.2.1
+CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+KERNELNAME:="uImage"
+
+DEFAULT_PACKAGES += uboot-omap4-omap4_panda
+
+DEVICE_TYPE=developerboard
+
+define Target/Description
+ TI OMAP4
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))