aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-07-24 19:43:45 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-07-24 19:43:45 +0000
commit5092abf8e56b59aeb9bd49199b898409b7729736 (patch)
tree64686bb8166c5bccd5682d68467a39c5f0b8331b /target/linux/omap24xx
parent5fe018c3931640ed8466ff51e76e17561756b8d2 (diff)
downloadmaster-187ad058-5092abf8e56b59aeb9bd49199b898409b7729736.tar.gz
master-187ad058-5092abf8e56b59aeb9bd49199b898409b7729736.tar.bz2
master-187ad058-5092abf8e56b59aeb9bd49199b898409b7729736.zip
[omap24x] move target specific modules to target's module.mk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32808 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap24xx')
-rw-r--r--target/linux/omap24xx/modules.mk46
1 files changed, 46 insertions, 0 deletions
diff --git a/target/linux/omap24xx/modules.mk b/target/linux/omap24xx/modules.mk
new file mode 100644
index 0000000000..1664e05c89
--- /dev/null
+++ b/target/linux/omap24xx/modules.mk
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/sound-soc-omap
+ TITLE:=OMAP SoC sound support
+ KCONFIG:= \
+ CONFIG_SND_OMAP_SOC
+ FILES:=$(LINUX_DIR)/sound/soc/omap/snd-soc-omap.ko
+ AUTOLOAD:=$(call AutoLoad,60,snd-soc-omap)
+ DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-core
+ $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-omap))
+
+
+define KernelPackage/sound-soc-omap-mcbsp
+ TITLE:=OMAP SoC MCBSP support
+ KCONFIG:= \
+ CONFIG_SND_OMAP_SOC_MCBSP
+ FILES:=$(LINUX_DIR)/sound/soc/omap/snd-soc-omap-mcbsp.ko
+ AUTOLOAD:=$(call AutoLoad,61,snd-soc-omap-mcbsp)
+ DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-omap
+ $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-omap-mcbsp))
+
+
+define KernelPackage/sound-soc-n810
+ TITLE:=Nokia n810 SoC sound support
+ KCONFIG:= \
+ CONFIG_SND_OMAP_SOC_N810
+ FILES:= \
+ $(LINUX_DIR)/sound/soc/codecs/snd-soc-tlv320aic3x.ko \
+ $(LINUX_DIR)/sound/soc/omap/snd-soc-n810.ko
+ AUTOLOAD:=$(call AutoLoad,65,snd-soc-tlv320aic3x snd-soc-n810)
+ DEPENDS:=@TARGET_omap24xx +kmod-sound-soc-omap +kmod-sound-soc-omap-mcbsp
+ $(call AddDepends/sound)
+endef
+
+$(eval $(call KernelPackage,sound-soc-n810))