aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-06-05 20:58:55 +0000
committerJonas Gorski <jogo@openwrt.org>2013-06-05 20:58:55 +0000
commit44dd2540acacf2f3fcb3fd325133d67696e7b271 (patch)
tree1a1cc9fd4022748a7a94c612f35d48656d62e85a /target/linux/omap24xx
parentc926c403ad62ebf38afdbfe786ecb07dfee89485 (diff)
downloadmaster-187ad058-44dd2540acacf2f3fcb3fd325133d67696e7b271.tar.gz
master-187ad058-44dd2540acacf2f3fcb3fd325133d67696e7b271.tar.bz2
master-187ad058-44dd2540acacf2f3fcb3fd325133d67696e7b271.zip
omap24xx: convert to use the new jffs2_nand
Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36862 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap24xx')
-rw-r--r--target/linux/omap24xx/Makefile2
-rw-r--r--target/linux/omap24xx/image/Makefile4
2 files changed, 2 insertions, 4 deletions
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
index 7a7e4d8bf3..5998b4db7e 100644
--- a/target/linux/omap24xx/Makefile
+++ b/target/linux/omap24xx/Makefile
@@ -10,7 +10,7 @@ ARCH:=arm
BOARD:=omap24xx
BOARDNAME:=TI OMAP24xx
MAINTAINER:=Michael Buesch <m@bues.ch>
-FEATURES:=targz squashfs jffs2 usb usbgadget display gpio audio broken
+FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
LINUX_VERSION:=3.3.8
diff --git a/target/linux/omap24xx/image/Makefile b/target/linux/omap24xx/image/Makefile
index 682109a249..24e9b76744 100644
--- a/target/linux/omap24xx/image/Makefile
+++ b/target/linux/omap24xx/image/Makefile
@@ -7,9 +7,7 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-JFFS2_BLOCKSIZE=128k
-JFFS2OPTS += --little-endian --pagesize=0x800 --no-cleanmarkers --pad
-
+NAND_BLOCKSIZE=2048:128k
define Image/BuildKernel
$(CP) $(LINUX_DIR)/arch/arm/boot/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage