aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/omap24xx/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2010-08-08 14:16:48 +0000
committerMichael Büsch <mb@bu3sch.de>2010-08-08 14:16:48 +0000
commita4c446a2bc4024ddef2a259d97dae5b0671c1fea (patch)
treea40a40e5bfc0cbdf6bb708cbcdc68851de49c951 /target/linux/omap24xx/Makefile
parent3a4b11a5ef3a4dc781bdf24788801c6d281f2378 (diff)
downloadmaster-187ad058-a4c446a2bc4024ddef2a259d97dae5b0671c1fea.tar.gz
master-187ad058-a4c446a2bc4024ddef2a259d97dae5b0671c1fea.tar.bz2
master-187ad058-a4c446a2bc4024ddef2a259d97dae5b0671c1fea.zip
Add omap24xx.
Boots the kernel with working video and serial console. Userland is untested. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22530 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/omap24xx/Makefile')
-rw-r--r--target/linux/omap24xx/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/omap24xx/Makefile b/target/linux/omap24xx/Makefile
new file mode 100644
index 0000000000..2d04d7c80c
--- /dev/null
+++ b/target/linux/omap24xx/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=arm
+BOARD:=omap24xx
+BOARDNAME:=TI OMAP-24xx
+FEATURES:=jffs2
+
+LINUX_VERSION:=2.6.35
+
+define Target/Description
+ TI OMAP-24xx
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))