aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-10-06 20:05:39 +0000
committerJohn Crispin <blogic@openwrt.org>2014-10-06 20:05:39 +0000
commitf45d8eb92123f8890ac8927ee364e01f4eaac4dd (patch)
tree2c6cab82e2d3739d358f967a09a0c3ba6b60dd7f /target/linux/octeon
parent5dc87ed592a64d8165b3772ff466f6be4f7b161a (diff)
downloadmaster-187ad058-f45d8eb92123f8890ac8927ee364e01f4eaac4dd.tar.gz
master-187ad058-f45d8eb92123f8890ac8927ee364e01f4eaac4dd.tar.bz2
master-187ad058-f45d8eb92123f8890ac8927ee364e01f4eaac4dd.zip
octeon: prepare elf kernel image and md5sum for usb copying
Signed-off-by: Roman Yeryomin <roman@advem.lv> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42809 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index 25a81496b2..f06dd6bcfe 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -12,6 +12,8 @@ define Image/BuildKernel
$(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
$(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/$(IMG_PREFIX)-vmlinux.lzma bs=65536 conv=sync
+ $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/vmlinux.64
+ md5sum $(BIN_DIR)/vmlinux.64 | cut -d " " -f 1 | tee $(BIN_DIR)/vmlinux.64.md5
endef
define Image/Build/squashfs