aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/octeon
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-05-29 11:28:20 +0000
committerJohn Crispin <blogic@openwrt.org>2015-05-29 11:28:20 +0000
commit1cf47d87923700b395c47b0e908f37c002df121b (patch)
tree9e2ac2f5472d1c9b0ccec1accb7b80af64f08c2d /target/linux/octeon
parentb15b638a588762ac41ab3f944d37684734a1a078 (diff)
downloadmaster-187ad058-1cf47d87923700b395c47b0e908f37c002df121b.tar.gz
master-187ad058-1cf47d87923700b395c47b0e908f37c002df121b.tar.bz2
master-187ad058-1cf47d87923700b395c47b0e908f37c002df121b.zip
octeon: fix imagebuilder
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45821 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/octeon')
-rw-r--r--target/linux/octeon/image/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/target/linux/octeon/image/Makefile b/target/linux/octeon/image/Makefile
index a15e87b0c9..e74b06dd4b 100644
--- a/target/linux/octeon/image/Makefile
+++ b/target/linux/octeon/image/Makefile
@@ -7,9 +7,13 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
-define Image/BuildKernel/Template
+define Image/Prepare
# Workaround pre-SDK-1.9.0 u-boot versions not handling the .notes section
- $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64
+ $(TARGET_CROSS)strip -R .notes $(KDIR)/vmlinux.elf -o $(KDIR)/vmlinux.elf.stripped
+endef
+
+define Image/BuildKernel/Template
+ $(CP) $(KDIR)/vmlinux.elf.stripped $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64
$(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64 '$(strip $(2))'
md5sum $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64 | cut -d " " -f 1 | tee $(BIN_DIR)/$(IMG_PREFIX)-$(1)-vmlinux.64.md5
endef