aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/netlogic/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2014-10-24 00:16:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2014-10-24 00:16:23 +0000
commita1cb12525c4c2cd9a1dc302ba31ee464d7138ed3 (patch)
tree1028ed2689868992479f6c2d97974fcec1d56de3 /target/linux/netlogic/image/Makefile
parent1d93f1cc508dfd541b8489083527c23cb27d4892 (diff)
downloadmaster-187ad058-a1cb12525c4c2cd9a1dc302ba31ee464d7138ed3.tar.gz
master-187ad058-a1cb12525c4c2cd9a1dc302ba31ee464d7138ed3.tar.bz2
master-187ad058-a1cb12525c4c2cd9a1dc302ba31ee464d7138ed3.zip
netlogic: add XLR/XLP support
Add support for Broadcom/Netlogic XLR/XLP support Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43037 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/netlogic/image/Makefile')
-rw-r--r--target/linux/netlogic/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/netlogic/image/Makefile b/target/linux/netlogic/image/Makefile
new file mode 100644
index 0000000000..6dde9b0e59
--- /dev/null
+++ b/target/linux/netlogic/image/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2009-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/BuildKernel
+endef
+
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+ $(call Image/Build/$(1))
+ dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
+endef
+
+$(eval $(call BuildImage))