aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2014-12-12 11:39:22 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2014-12-12 11:39:22 +0000
commit8d8fac58fe79f0bf0e941ecbfeb9290b5073a352 (patch)
treee4ad7c4f4e634e94b2bf3093d07570139bef69ba /target/linux/mxs
parent1b4898f87dab1d35ae71df44ed9ce9343d495e45 (diff)
downloadmaster-187ad058-8d8fac58fe79f0bf0e941ecbfeb9290b5073a352.tar.gz
master-187ad058-8d8fac58fe79f0bf0e941ecbfeb9290b5073a352.tar.bz2
master-187ad058-8d8fac58fe79f0bf0e941ecbfeb9290b5073a352.zip
mxs: i2c changes
- add package for i2c module - remove i2c debug Signed-off-by: Michael Heimpold <mhei@heimpold.de> Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43648 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/config-3.145
-rw-r--r--target/linux/mxs/modules.mk15
2 files changed, 16 insertions, 4 deletions
diff --git a/target/linux/mxs/config-3.14 b/target/linux/mxs/config-3.14
index bded4131d9..ead8dc3577 100644
--- a/target/linux/mxs/config-3.14
+++ b/target/linux/mxs/config-3.14
@@ -157,15 +157,12 @@ CONFIG_I2C_ALGOPCF=y
CONFIG_I2C_BOARDINFO=y
CONFIG_I2C_CHARDEV=y
CONFIG_I2C_COMPAT=y
-CONFIG_I2C_DEBUG_ALGO=y
-CONFIG_I2C_DEBUG_BUS=y
-CONFIG_I2C_DEBUG_CORE=y
CONFIG_I2C_MUX=y
# CONFIG_I2C_MUX_GPIO is not set
# CONFIG_I2C_MUX_PCA9541 is not set
# CONFIG_I2C_MUX_PCA954x is not set
CONFIG_I2C_MUX_PINCTRL=y
-CONFIG_I2C_MXS=y
+# CONFIG_I2C_MXS is not set
CONFIG_IIO=y
CONFIG_IIO_BUFFER=y
CONFIG_IIO_KFIFO_BUF=y
diff --git a/target/linux/mxs/modules.mk b/target/linux/mxs/modules.mk
index afcf23865c..75d668a1d0 100644
--- a/target/linux/mxs/modules.mk
+++ b/target/linux/mxs/modules.mk
@@ -99,3 +99,18 @@ define KernelPackage/spi-mxs/description
endef
$(eval $(call KernelPackage,spi-mxs))
+
+I2C_MXS_MODULES:= \
+ CONFIG_I2C_MXS:drivers/i2c/busses/i2c-mxs
+
+define KernelPackage/i2c-mxs
+ $(call i2c_defaults,$(I2C_MXS_MODULES),55)
+ TITLE:=Freescale i.MX23/28 I2C driver
+ DEPENDS:=@TARGET_mxs +kmod-i2c-core
+endef
+
+define KernelPackage/i2c-mxs/description
+ Kernel module for Freescale i.MX23/28 I2C controller
+endef
+
+$(eval $(call KernelPackage,i2c-mxs))