aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-12-11 18:35:41 +0000
committerJohn Crispin <blogic@openwrt.org>2014-12-11 18:35:41 +0000
commit046c63d70762ac2639cf87afb44548466ad0c327 (patch)
treedf91726893c4560255387a02b0f52503dc3b34f6 /target/linux/mxs
parent154f8ef0d814635d48950de09bc169106c00e8a1 (diff)
downloadmaster-187ad058-046c63d70762ac2639cf87afb44548466ad0c327.tar.gz
master-187ad058-046c63d70762ac2639cf87afb44548466ad0c327.tar.bz2
master-187ad058-046c63d70762ac2639cf87afb44548466ad0c327.zip
kernel/modules: fix chipidea
it should needs to depend on imx and mxs also remove duplicate kmod definition from mxs target Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43627 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mxs')
-rw-r--r--target/linux/mxs/modules.mk18
1 files changed, 1 insertions, 17 deletions
diff --git a/target/linux/mxs/modules.mk b/target/linux/mxs/modules.mk
index 3f9c8f8334..10ea3d685f 100644
--- a/target/linux/mxs/modules.mk
+++ b/target/linux/mxs/modules.mk
@@ -33,22 +33,6 @@ endef
$(eval $(call KernelPackage,wdt-stmp3xxx))
-define KernelPackage/usb-chipidea-imx
- TITLE:=Support for ChipIdea controllers on Freescale i.MX SoCs
- DEPENDS:=+kmod-usb-chipidea @TARGET_mxs
- FILES:= \
- $(LINUX_DIR)/drivers/usb/chipidea/ci_hdrc_imx.ko \
- $(LINUX_DIR)/drivers/usb/chipidea/usbmisc_imx.ko
- AUTOLOAD:=$(call AutoLoad,52,usbmisc_imx ci_hdrc_imx,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/usb-chipidea-imx/description
- Kernel support for USB ChipIdea controllers on Freescale i.MX SoCs
-endef
-
-$(eval $(call KernelPackage,usb-chipidea-imx,1))
-
define KernelPackage/sound-soc-mxs
TITLE:=Freescale i.MX23/i.MX28 built-in SoC sound support
KCONFIG:= \
@@ -63,7 +47,7 @@ define KernelPackage/sound-soc-mxs
DEPENDS:=@TARGET_mxs +kmod-sound-soc-core
$(call AddDepends/sound)
endef
-
+
define KernelPackage/sound-soc-mxs/description
Kernel support for Freescale i.MX23/i.MX28 built-in SoC audio
endef