aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mxs/profiles/01-duckbill.mk
diff options
context:
space:
mode:
authorZoltan HERPAI <wigyori@uid0.hu>2014-05-03 14:56:25 +0000
committerZoltan HERPAI <wigyori@uid0.hu>2014-05-03 14:56:25 +0000
commita619a87d01a68fede0ee30955baafa994962fea1 (patch)
treec6db036efbedfaac5ec8e4e37c0686fc77943c04 /target/linux/mxs/profiles/01-duckbill.mk
parent8f82b19fd536b2184369500feee71dd7a97b1c70 (diff)
downloadmaster-187ad058-a619a87d01a68fede0ee30955baafa994962fea1.tar.gz
master-187ad058-a619a87d01a68fede0ee30955baafa994962fea1.tar.bz2
master-187ad058-a619a87d01a68fede0ee30955baafa994962fea1.zip
mxs: rename files so that profiles are sorted alphabetically
While at it, make spelling at little bit more consistent, at least for my taste :-) Signed-off-by: Michael Heimpold <mhei@heimpold.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40679 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mxs/profiles/01-duckbill.mk')
-rw-r--r--target/linux/mxs/profiles/01-duckbill.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/mxs/profiles/01-duckbill.mk b/target/linux/mxs/profiles/01-duckbill.mk
new file mode 100644
index 0000000000..3f75a7aa77
--- /dev/null
+++ b/target/linux/mxs/profiles/01-duckbill.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/duckbill
+ NAME:=I2SE Duckbill boards
+ DEPENDS:=+@TARGET_ROOTFS_INCLUDE_KERNEL +@TARGET_ROOTFS_INCLUDE_DTB
+ FEATURES+=usbgadget
+ PACKAGES+= \
+ -dnsmasq -firewall -ppp -ip6tables -iptables -6relayd -mtd uboot-envtools \
+ kmod-leds-gpio kmod-ledtrig-timer kmod-usb-mxs-phy -kmod-ipt-nathelper
+endef
+
+define Profile/duckbill/Description
+ I2SE's Duckbill devices
+endef
+
+$(eval $(call Profile,duckbill))