aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles/plathome.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-02-06 11:16:20 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-02-06 11:16:20 +0000
commit32a16916adf44e5f32866f3057b78f31ad03df17 (patch)
tree933a8683e9d2fd66671a548dd150330a15ba6356 /target/linux/mvebu/profiles/plathome.mk
parentdaf0abacc23a518af69fdf049b3a598181cbfd26 (diff)
downloadmaster-187ad058-32a16916adf44e5f32866f3057b78f31ad03df17.tar.gz
master-187ad058-32a16916adf44e5f32866f3057b78f31ad03df17.tar.bz2
master-187ad058-32a16916adf44e5f32866f3057b78f31ad03df17.zip
mvebu: support building images for a single board
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44290 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/profiles/plathome.mk')
-rw-r--r--target/linux/mvebu/profiles/plathome.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/mvebu/profiles/plathome.mk b/target/linux/mvebu/profiles/plathome.mk
new file mode 100644
index 0000000000..fac31e6fc6
--- /dev/null
+++ b/target/linux/mvebu/profiles/plathome.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/OpenBlocks-AX-3-4
+ NAME:=Plat'Home OpenBlocks AX3
+ PACKAGES:= \
+ kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/OpenBlocks-AX-3-4/Description
+ Package set compatible with the Plat'Home OpenBlocks AX3.
+endef
+
+$(eval $(call Profile,OpenBlocks-AX-3-4))