aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mvebu/profiles/200-Evalboards.mk
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2014-07-01 09:43:38 +0000
committerImre Kaloz <kaloz@openwrt.org>2014-07-01 09:43:38 +0000
commit8dd40de14951643a960bdbf04fa1df00ea6f2ceb (patch)
tree515836ab91312fc74557522e548b925e31b3b865 /target/linux/mvebu/profiles/200-Evalboards.mk
parent67be4d585d6882c883eaf7b0501f2b197b035691 (diff)
downloadmaster-187ad058-8dd40de14951643a960bdbf04fa1df00ea6f2ceb.tar.gz
master-187ad058-8dd40de14951643a960bdbf04fa1df00ea6f2ceb.tar.bz2
master-187ad058-8dd40de14951643a960bdbf04fa1df00ea6f2ceb.zip
[mvebu]: adjust default profile, and add an evalboard one
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41435 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mvebu/profiles/200-Evalboards.mk')
-rw-r--r--target/linux/mvebu/profiles/200-Evalboards.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/mvebu/profiles/200-Evalboards.mk b/target/linux/mvebu/profiles/200-Evalboards.mk
new file mode 100644
index 0000000000..52d0b9803d
--- /dev/null
+++ b/target/linux/mvebu/profiles/200-Evalboards.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2013-2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Evalboards
+ NAME:=Evaluation / Development boards
+ PACKAGES:= \
+ kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
+ kmod-of-i2c kmod-i2c-core kmod-i2c-mv64xxx \
+ kmod-ata-core kmod-ata-marvell-sata \
+ kmod-rtc-marvell kmod-thermal-armada
+endef
+
+define Profile/Evalboards/Description
+ Package set compatible with most Marvell Armada 370/XP development based boards.
+endef
+
+$(eval $(call Profile,Evalboards))