aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc85xx/profiles
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-03-15 16:11:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-03-15 16:11:45 +0000
commitf6f637f2ed1ac81deb3d86380f3a3eae855927bc (patch)
treeb81976248019e24fcbb1a06ab21a952ddca546fe /target/linux/mpc85xx/profiles
parent562eca38dcfeee1d986b616ad2a1a496f8afde47 (diff)
downloadmaster-187ad058-f6f637f2ed1ac81deb3d86380f3a3eae855927bc.tar.gz
master-187ad058-f6f637f2ed1ac81deb3d86380f3a3eae855927bc.tar.bz2
master-187ad058-f6f637f2ed1ac81deb3d86380f3a3eae855927bc.zip
mpc85xx: add profile and build image for the TL-WDR4900 v1 board
Now that the ethernet switch is working, create firmware images to make impatient users happy. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36051 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc85xx/profiles')
-rw-r--r--target/linux/mpc85xx/profiles/tp-link.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/mpc85xx/profiles/tp-link.mk b/target/linux/mpc85xx/profiles/tp-link.mk
new file mode 100644
index 0000000000..57981d377c
--- /dev/null
+++ b/target/linux/mpc85xx/profiles/tp-link.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TLWDR4900
+ NAME:=TP-Link TL-WDR4900
+ PACKAGES:=\
+ kmod-usb-core kmod-usb2 kmod-usb2-fsl \
+ kmod-ath9k kmod-wpad
+endef
+
+define Profile/TLWDR4900/Description
+ Package set optimized for the TP-Link TL-WDR4900.
+endef
+$(eval $(call Profile,TLWDR4900))