aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc83xx/image
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2010-01-10 18:14:23 +0000
committerImre Kaloz <kaloz@openwrt.org>2010-01-10 18:14:23 +0000
commit28eef087773b07334a8c7fc9c58f0d4fc0ea9fe7 (patch)
tree7eb8281cfc687bae9dc3d7c1da13d3cbf26884e7 /target/linux/mpc83xx/image
parent1095640d8ff4ceba476f41fd16b65dc83e8db021 (diff)
downloadmaster-187ad058-28eef087773b07334a8c7fc9c58f0d4fc0ea9fe7.tar.gz
master-187ad058-28eef087773b07334a8c7fc9c58f0d4fc0ea9fe7.tar.bz2
master-187ad058-28eef087773b07334a8c7fc9c58f0d4fc0ea9fe7.zip
[mpc83xx]: FIT uImage support for the MPC8377-WLAN
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19094 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc83xx/image')
-rw-r--r--target/linux/mpc83xx/image/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/target/linux/mpc83xx/image/Makefile b/target/linux/mpc83xx/image/Makefile
index 8004f746b5..ed00128999 100644
--- a/target/linux/mpc83xx/image/Makefile
+++ b/target/linux/mpc83xx/image/Makefile
@@ -9,7 +9,6 @@ include $(INCLUDE_DIR)/image.mk
define Image/Prepare
- $(LINUX_DIR)/scripts/dtc/dtc -O dtb -R 4 -S 0x20000 $(LINUX_DIR)/arch/powerpc/boot/dts/mpc8377_wlan.dts > $(KDIR)/openwrt-mpc8377_wlan.dtb
endef
define Image/BuildKernel
@@ -22,12 +21,10 @@ endef
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-# We'll do FIT here
-# ( \
-# dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage bs=1920k conv=sync; \
-# dd if=$(KDIR)/openwrt-mpc8377_wlan.dtb bs=128k conv=sync; \
-# dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
-# ) > $(BIN_DIR)/openwrt-$(BOARD)-mpc8377_wlan-$(1).img
+ ( \
+ dd if=$(LINUX_DIR)/arch/powerpc/boot/uImage.fit.mpc8377_wlan bs=3072k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=256k conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-mpc8377_wlan-$(1).img
endef
$(eval $(call BuildImage))