aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mpc52xx/image/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-12 23:15:56 +0000
commit9d42bb1a218d092b8c9447cf16ec2c94f7881c8d (patch)
tree422842a370190fdfcc59b10055cbbf761974bb76 /target/linux/mpc52xx/image/Makefile
parentdebf59c4e6f85df3132eae86b2e8c8399040c1ce (diff)
downloadmaster-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.tar.gz
master-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.tar.bz2
master-187ad058-9d42bb1a218d092b8c9447cf16ec2c94f7881c8d.zip
define a shared IMG_PREFIX variable used as a basename for image files, it contains board & subtarget infos (if appropriate) allowing subtargets to share the same bin directory without overwriting each other's files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20834 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mpc52xx/image/Makefile')
-rw-r--r--target/linux/mpc52xx/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/mpc52xx/image/Makefile b/target/linux/mpc52xx/image/Makefile
index 177ca07bb7..b63a78dc57 100644
--- a/target/linux/mpc52xx/image/Makefile
+++ b/target/linux/mpc52xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -12,11 +12,11 @@ define Image/Prepare
endef
define Image/BuildKernel
- cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
+ cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
endef
define Image/Build/ext2
- cp $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-ext2.img
+ cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-ext2.img
endef
define Image/Build