aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-01-10 20:11:18 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-01-10 20:11:18 +0000
commit03e961eb20b65edfbcdc6ccf3d82667ad36246c7 (patch)
tree5cd89f5fe4ed09765f0dc70c75f4122360c955a7 /target/linux/mcs814x
parent1e7c30a28ff2ee87fe8796d7f6f9dbf73123e2c6 (diff)
downloadmaster-187ad058-03e961eb20b65edfbcdc6ccf3d82667ad36246c7.tar.gz
master-187ad058-03e961eb20b65edfbcdc6ccf3d82667ad36246c7.tar.bz2
master-187ad058-03e961eb20b65edfbcdc6ccf3d82667ad36246c7.zip
mcs814x: account for dtb output directory differences
3.3 produced *.dtb files in arch/arm/boot/ while 3.14 will produce those in arch/arm/boot/dts/, adjust the image makefile accordingly. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43925 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x')
-rw-r--r--target/linux/mcs814x/image/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 1c814fa4fd..7f8722d6bd 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -9,6 +9,12 @@ include $(INCLUDE_DIR)/image.mk
TARGET_DTBS := rbt-832 dlan-usb-extender
+ifeq ($(KERNEL_PATCHVER),3.3)
+DTBS_DIR:=
+else
+DTBS_DIR:=dts/
+endif
+
LOADADDR:=0x00008000
JFFS2_BLOCKSIZE = 128k
@@ -22,7 +28,7 @@ endef
define Image/Build/DTB
cp $(KDIR)/zImage$(2) $(KDIR)/zImage-$(1);
- cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
+ cat $(LINUX_DIR)/arch/$(ARCH)/boot/$(DTBS_DIR)$(1).dtb >> $(KDIR)/zImage$(2)-$(1);
$(call Image/Build/MkuImage,$(KDIR)/zImage$(2)-$(1),$(KDIR)/uImage$(2)-$(1))
cp $(KDIR)/uImage$(2)-$(1) $(UIMAGE)$(2)-$(1);
endef