aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:40 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:40 +0000
commitc5fa46dc5f0cc9f973c75f20e6b20848ddc898c4 (patch)
tree5dc17e5582482b7bd28000bb05fed8966646be2b /target/linux/mcs814x/profiles
parenta7b6531eea8816a1987e5fcb0e2c0c9c32a12680 (diff)
downloadmaster-187ad058-c5fa46dc5f0cc9f973c75f20e6b20848ddc898c4.tar.gz
master-187ad058-c5fa46dc5f0cc9f973c75f20e6b20848ddc898c4.tar.bz2
master-187ad058-c5fa46dc5f0cc9f973c75f20e6b20848ddc898c4.zip
[mcs814x] add Generic and dLAN USB Extender profiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33313 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/profiles')
-rw-r--r--target/linux/mcs814x/profiles/000-Generic.mk16
-rw-r--r--target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk17
2 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/mcs814x/profiles/000-Generic.mk b/target/linux/mcs814x/profiles/000-Generic.mk
new file mode 100644
index 0000000000..a6d0f30ec5
--- /dev/null
+++ b/target/linux/mcs814x/profiles/000-Generic.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+ NAME:=Generic profile
+endef
+
+define Profile/Generic/Description
+ Default profile for Moschip MCS814x targets
+endef
+$(eval $(call Profile,Generic))
+
diff --git a/target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk b/target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk
new file mode 100644
index 0000000000..86aa5f8769
--- /dev/null
+++ b/target/linux/mcs814x/profiles/100-dLAN-USB-Extender.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/dLAN_USB_Extender
+ NAME:=Devolo dLAN USB Extender
+ PACKAGES:=hpavcfg foot
+endef
+
+define Profile/dLAN_USB_Extender/Description
+ Package set specifically tuned for the Devolo dLAN USB Extender device.
+endef
+$(eval $(call Profile,dLAN_USB_Extender))
+