aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2015-04-04 18:01:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2015-04-04 18:01:07 +0000
commitd030e21a01634dd74b84b4b1de55fe1a86ad1a15 (patch)
treea06c2ec374a34c9b7fff6551e596e381eb87e263 /target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch
parent71f35a88e4666f4f310efb4563ebfce54045636f (diff)
downloadmaster-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.tar.gz
master-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.tar.bz2
master-187ad058-d030e21a01634dd74b84b4b1de55fe1a86ad1a15.zip
mcs814x: add support for 3.18
Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45273 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch')
-rw-r--r--target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch b/target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch
new file mode 100644
index 0000000000..92c85a700f
--- /dev/null
+++ b/target/linux/mcs814x/patches-3.18/008-mcs814x_gpio.patch
@@ -0,0 +1,25 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -819,6 +819,12 @@ config GPIO_MC33880
+ SPI driver for Freescale MC33880 high-side/low-side switch.
+ This provides GPIO interface supporting inputs and outputs.
+
++config GPIO_MCS814X
++ tristate "Moschip MCS814x GPIO support"
++ depends on ARCH_MCS814X
++ help
++ GPIO driver for Moschip MCS814x SoC gpio controllers.
++
+ config GPIO_74X164
+ tristate "74x164 serial-in/parallel-out 8-bits shift register"
+ depends on SPI_MASTER && OF
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -49,6 +49,7 @@ obj-$(CONFIG_GPIO_MAX732X) += gpio-max73
+ obj-$(CONFIG_GPIO_MC33880) += gpio-mc33880.o
+ obj-$(CONFIG_GPIO_MC9S08DZ60) += gpio-mc9s08dz60.o
+ obj-$(CONFIG_GPIO_MCP23S08) += gpio-mcp23s08.o
++obj-$(CONFIG_GPIO_MCS814X) += gpio-mcs814x.o
+ obj-$(CONFIG_GPIO_ML_IOH) += gpio-ml-ioh.o
+ obj-$(CONFIG_GPIO_MM_LANTIQ) += gpio-mm-lantiq.o
+ obj-$(CONFIG_GPIO_MOXART) += gpio-moxart.o