aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/mcs814x/image
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2012-09-03 20:25:46 +0000
commitb1e622e77602afa0bcf1dd5fea9ce5fcbe218f2f (patch)
tree3460c0c3a5a1614e37e7985afd4001f86d341a6c /target/linux/mcs814x/image
parentc5fa46dc5f0cc9f973c75f20e6b20848ddc898c4 (diff)
downloadmaster-187ad058-b1e622e77602afa0bcf1dd5fea9ce5fcbe218f2f.tar.gz
master-187ad058-b1e622e77602afa0bcf1dd5fea9ce5fcbe218f2f.tar.bz2
master-187ad058-b1e622e77602afa0bcf1dd5fea9ce5fcbe218f2f.zip
[mcs814x] pad squashfs image
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33314 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/mcs814x/image')
-rw-r--r--target/linux/mcs814x/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/mcs814x/image/Makefile b/target/linux/mcs814x/image/Makefile
index 5545e042e6..7386db0766 100644
--- a/target/linux/mcs814x/image/Makefile
+++ b/target/linux/mcs814x/image/Makefile
@@ -45,6 +45,10 @@ define Image/BuildKernel
$(call Image/Build/Initramfs)
endef
+define Image/Build/squashfs
+ $(STAGING_DIR_HOST)/bin/padjffs2 $(KDIR)/root.squashfs 128
+endef
+
define Image/Build
$(call Image/Build/$(1))
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync