aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/magicbox-2.6
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-10 21:52:28 +0000
commit53aef8417d5b9e00e4b74b022ed03975c732d8e9 (patch)
tree56570ca509d7826cb8163622a96ddac70562068c /target/linux/magicbox-2.6
parentbf32023e6c902f04f995d7e787a72129794a16ba (diff)
downloadmaster-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.gz
master-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.tar.bz2
master-187ad058-53aef8417d5b9e00e4b74b022ed03975c732d8e9.zip
Add initial version of the new Image Builder
It's still a bit rough in a few places, but it seems to work for Broadcom at least - other targets untested. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6071 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/magicbox-2.6')
-rw-r--r--target/linux/magicbox-2.6/image/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/magicbox-2.6/image/Makefile b/target/linux/magicbox-2.6/image/Makefile
index 10f71df2a9..77ff88f521 100644
--- a/target/linux/magicbox-2.6/image/Makefile
+++ b/target/linux/magicbox-2.6/image/Makefile
@@ -11,10 +11,11 @@ define Build/Clean
endef
define Image/Prepare
+ cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
endef
define Image/BuildKernel
- cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+ cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
endef
define Image/Build
@@ -23,7 +24,7 @@ endef
define Image/Build/jffs2-64k
( \
- dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=65536 conv=sync; \
+ dd if=$(KDIR)/uImage bs=65536 conv=sync; \
dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
endef