aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/magicbox-2.6/image/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2007-05-26 15:36:22 +0000
committerImre Kaloz <kaloz@openwrt.org>2007-05-26 15:36:22 +0000
commit4c730be09cfe80628bc2edfee2a864b1c89256c8 (patch)
tree35a3f0d080f6257e2b1630d8eb540150ffa34d6e /target/linux/magicbox-2.6/image/Makefile
parent0825e4952db006f6ffd2a38ea067c513144228c2 (diff)
downloadmaster-187ad058-4c730be09cfe80628bc2edfee2a864b1c89256c8.tar.gz
master-187ad058-4c730be09cfe80628bc2edfee2a864b1c89256c8.tar.bz2
master-187ad058-4c730be09cfe80628bc2edfee2a864b1c89256c8.zip
fix magicbox, convert mtd mapping to platform_device, add support for combined flash layout
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7336 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/magicbox-2.6/image/Makefile')
-rw-r--r--target/linux/magicbox-2.6/image/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/target/linux/magicbox-2.6/image/Makefile b/target/linux/magicbox-2.6/image/Makefile
index fe68f35d5e..f99590f1ea 100644
--- a/target/linux/magicbox-2.6/image/Makefile
+++ b/target/linux/magicbox-2.6/image/Makefile
@@ -21,16 +21,17 @@ endef
define Image/Build/jffs2-64k
( \
- dd if=$(KDIR)/uImage bs=65536 conv=sync; \
+ dd if=$(KDIR)/uImage bs=1024k conv=sync; \
dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
endef
-#define Image/Build/jffs2-128k
-# ( \
-# dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=131072 conv=sync; \
-# dd if=$(KDIR)/root.$(1) bs=131072 conv=sync; \
-# ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
-#endef
+define Image/Build/squashfs
+ $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+ ( \
+ dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=1024k conv=sync; \
+ dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
+ ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+endef
$(eval $(call BuildImage))