aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/magicbox-2.6/Makefile
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2006-08-25 21:53:54 +0000
committerImre Kaloz <kaloz@openwrt.org>2006-08-25 21:53:54 +0000
commitd5a6e89b8ff788cdcc0f195857ff042be1bf3116 (patch)
treedea67c0d50a3959429bbf0094651a6a420548313 /target/linux/magicbox-2.6/Makefile
parent13eef022bd62bc990528bdf61a705d1c96a27f11 (diff)
downloadmaster-187ad058-d5a6e89b8ff788cdcc0f195857ff042be1bf3116.tar.gz
master-187ad058-d5a6e89b8ff788cdcc0f195857ff042be1bf3116.tar.bz2
master-187ad058-d5a6e89b8ff788cdcc0f195857ff042be1bf3116.zip
add basic support for the Magicbox boards
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4672 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/magicbox-2.6/Makefile')
-rw-r--r--target/linux/magicbox-2.6/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/magicbox-2.6/Makefile b/target/linux/magicbox-2.6/Makefile
new file mode 100644
index 0000000000..7ffd11c668
--- /dev/null
+++ b/target/linux/magicbox-2.6/Makefile
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+LINUX_VERSION:=2.6.17
+LINUX_RELEASE:=1
+LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
+
+include ./config
+include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/kernel-build.mk
+
+$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
+ [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches $(MAKE_TRACE)
+ [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches $(MAKE_TRACE)
+ @$(CP) config $(LINUX_DIR)/.config
+ touch $@
+