aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-30 12:18:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-30 12:18:22 +0000
commitdd8f5d905f31f7b2e8b81da8ee2851fb8b508ffb (patch)
treed5c29bb067fc64692641baf7de06c47963d99d12 /target/linux/lantiq
parent864b924080af1c5f2f8b02ef008995aa90459f4a (diff)
downloadmaster-187ad058-dd8f5d905f31f7b2e8b81da8ee2851fb8b508ffb.tar.gz
master-187ad058-dd8f5d905f31f7b2e8b81da8ee2851fb8b508ffb.tar.bz2
master-187ad058-dd8f5d905f31f7b2e8b81da8ee2851fb8b508ffb.zip
lantiq: remove dead EASY33016 image recipe
Support for lantiq_svip_be has been removed a while ago, so EASY33016 images weren't buildable anymore. Remove the recipes as well as gzip compressed kernel support, as EASY33016 was the last user of it. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46760 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile35
1 files changed, 0 insertions, 35 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 0627b5bd7c..7980627e4e 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -60,22 +60,6 @@ define MkImageEVA
cat ./eva.dummy.squashfs >> $(KDIR)/$(1)$(2).eva.align.64k
endef
-define CompressGzip
- gzip -c $(1) > $(2)
-endef
-
-define PatchKernelGzip
- cp $(KDIR)/vmlinux$(3) $(KDIR)/vmlinux$(3)-$(1)
- $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux$(3)-$(1) '$(strip $(2))'
- $(call CompressGzip,$(KDIR)/vmlinux$(3)-$(1),$(KDIR)/vmlinux$(3)-$(1).gzip)
-endef
-
-define MkImageGzip
- mkimage -A mips -O linux -T kernel -a 0x80002000 -C gzip \
- -e 0x80002000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
- -d $(KDIR)/vmlinux$(2)-$(1).gzip $(KDIR)/uImage-$(1)$(2)
-endef
-
define Image/Build/squashfs
cat $(KDIR)/uImage-$(2) $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
$(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image)
@@ -284,17 +268,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
-define Image/BuildKernelGzip/Template
- $(call PatchKernelGzip,$(1),$(if $(2),$(2) machtype=$(1),))
- $(call MkImageGzip,$(1))
- $(CP) $(KDIR)/uImage-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage
-ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
- $(call PatchKernelGzip,$(1),$(if $(2),$(2) machtype=$(1),),-initramfs)
- $(call MkImageGzip,$(1),-initramfs)
- $(CP) $(KDIR)/uImage-$(1)-initramfs $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage-initramfs
-endif
-endef
-
ifeq ($(CONFIG_TARGET_lantiq_falcon),y)
@@ -457,14 +430,6 @@ endef
endif
-ifeq ($(CONFIG_TARGET_lantiq_svip_be),y)
-
-Image/BuildKernel/Profile/EASY33016=$(call Image/BuildKernelGzip/Template,EASY33016)
-Image/Build/Profile/EASY33016=$(call Image/Build/$(1),$(1),EASY33016)
-
-endif
-
-
define Image/BuildKernel
$(call Image/BuildKernel/Profile/$(PROFILE))
endef