aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-12-23 18:24:43 +0000
committerJohn Crispin <blogic@openwrt.org>2015-12-23 18:24:43 +0000
commitdb497f9f0cdbb23888183e39feb936b4f1bae1db (patch)
treef80b1efe94234e534d474efb02e852f652b1adad /target/linux/lantiq
parentd3051d44a94c3876f956d6cf5fe3ba77c44a901c (diff)
downloadmaster-187ad058-db497f9f0cdbb23888183e39feb936b4f1bae1db.tar.gz
master-187ad058-db497f9f0cdbb23888183e39feb936b4f1bae1db.tar.bz2
master-187ad058-db497f9f0cdbb23888183e39feb936b4f1bae1db.zip
lantiq: disable SW_PORTMAP usage in the ethernet driver
using the special tag in this way lead to port mirroring for certain types of traffic. fallback to using th PMAC_EWAN register for the wan portmap. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47993 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/patches-4.1/0025-NET-MIPS-lantiq-adds-xrx200-net.patch9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/lantiq/patches-4.1/0025-NET-MIPS-lantiq-adds-xrx200-net.patch b/target/linux/lantiq/patches-4.1/0025-NET-MIPS-lantiq-adds-xrx200-net.patch
index 48c7395cff..35a2e18a05 100644
--- a/target/linux/lantiq/patches-4.1/0025-NET-MIPS-lantiq-adds-xrx200-net.patch
+++ b/target/linux/lantiq/patches-4.1/0025-NET-MIPS-lantiq-adds-xrx200-net.patch
@@ -16,7 +16,7 @@ Subject: [PATCH 25/36] NET: MIPS: lantiq: adds xrx200-net
--- a/drivers/net/ethernet/Kconfig
+++ b/drivers/net/ethernet/Kconfig
-@@ -101,7 +101,13 @@ config LANTIQ_ETOP
+@@ -101,7 +101,13 @@
tristate "Lantiq SoC ETOP driver"
depends on SOC_TYPE_XWAY
---help---
@@ -33,7 +33,7 @@ Subject: [PATCH 25/36] NET: MIPS: lantiq: adds xrx200-net
source "drivers/net/ethernet/mellanox/Kconfig"
--- a/drivers/net/ethernet/Makefile
+++ b/drivers/net/ethernet/Makefile
-@@ -43,6 +43,7 @@ obj-$(CONFIG_IP1000) += icplus/
+@@ -43,6 +43,7 @@
obj-$(CONFIG_JME) += jme.o
obj-$(CONFIG_KORINA) += korina.o
obj-$(CONFIG_LANTIQ_ETOP) += lantiq_etop.o
@@ -209,7 +209,7 @@ Subject: [PATCH 25/36] NET: MIPS: lantiq: adds xrx200-net
+};
--- /dev/null
+++ b/drivers/net/ethernet/lantiq_xrx200.c
-@@ -0,0 +1,1798 @@
+@@ -0,0 +1,1797 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
@@ -248,7 +248,7 @@ Subject: [PATCH 25/36] NET: MIPS: lantiq: adds xrx200-net
+
+#define SW_POLLING
+#define SW_ROUTING
-+#define SW_PORTMAP
++/* #define SW_PORTMAP */
+
+#ifdef SW_ROUTING
+ #ifdef SW_PORTMAP
@@ -941,7 +941,6 @@ Subject: [PATCH 25/36] NET: MIPS: lantiq: adds xrx200-net
+
+static int xrx200_set_port_attr(struct switch_dev *dev, const struct switch_attr *attr, struct switch_val *val)
+{
-+ printk("%s %s(%d)\n", __FILE__, __func__, __LINE__);
+ if (val->port_vlan >= XRX200_MAX_PORT)
+ return -EINVAL;
+