aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-11 16:06:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-11 16:06:37 +0000
commitd3305e8570dba327c25bc62584e2874fbb3d2008 (patch)
tree6466a8c5f3d798497135e9e56cdc24fbd941602e /target/linux/lantiq
parent95b66c31118df52b4417fe2e070cbe75aa7d8ade (diff)
downloadmaster-187ad058-d3305e8570dba327c25bc62584e2874fbb3d2008.tar.gz
master-187ad058-d3305e8570dba327c25bc62584e2874fbb3d2008.tar.bz2
master-187ad058-d3305e8570dba327c25bc62584e2874fbb3d2008.zip
kernel: update 3.10 to 3.10.26
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39220 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/patches-3.10/0012-MTD-m25p80-allow-loading-mtd-name-from-OF.patch4
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 6a698c6ad4..fa7ac2555a 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs
SUBTARGETS=xway xrx200 ase falcon
-LINUX_VERSION:=3.10.24
+LINUX_VERSION:=3.10.26
CPU_TYPE:=mips32r2
diff --git a/target/linux/lantiq/patches-3.10/0012-MTD-m25p80-allow-loading-mtd-name-from-OF.patch b/target/linux/lantiq/patches-3.10/0012-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
index 3be1bebbe2..192579b0ce 100644
--- a/target/linux/lantiq/patches-3.10/0012-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
+++ b/target/linux/lantiq/patches-3.10/0012-MTD-m25p80-allow-loading-mtd-name-from-OF.patch
@@ -14,7 +14,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/mtd/devices/m25p80.c
+++ b/drivers/mtd/devices/m25p80.c
-@@ -925,10 +925,13 @@ static int m25p_probe(struct spi_device
+@@ -926,10 +926,13 @@ static int m25p_probe(struct spi_device
unsigned i;
struct mtd_part_parser_data ppdata;
struct device_node __maybe_unused *np = spi->dev.of_node;
@@ -28,7 +28,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#endif
/* Platform data helps sort out which chip type we have, as
-@@ -1004,6 +1007,8 @@ static int m25p_probe(struct spi_device
+@@ -1005,6 +1008,8 @@ static int m25p_probe(struct spi_device
if (data && data->name)
flash->mtd.name = data->name;