aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-11-05 08:25:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-11-05 08:25:45 +0000
commit717bb2a9cfa4ea7804db066746c5618aa747d508 (patch)
tree5dc258adc647d10c5431fbc84cc5eb38b47a1a00 /target/linux/lantiq
parent4a7d83ad5e3a377885ad6c9a4c1ddae38c3614bc (diff)
downloadmaster-187ad058-717bb2a9cfa4ea7804db066746c5618aa747d508.tar.gz
master-187ad058-717bb2a9cfa4ea7804db066746c5618aa747d508.tar.bz2
master-187ad058-717bb2a9cfa4ea7804db066746c5618aa747d508.zip
kernel: update 3.10 to 3.10.18
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38652 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/patches-3.10/0100-mtd-split.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 7b15754012..35d0a8b2b3 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs
SUBTARGETS=xway xrx200 ase falcon
-LINUX_VERSION:=3.10.17
+LINUX_VERSION:=3.10.18
CPU_TYPE:=mips32r2
diff --git a/target/linux/lantiq/patches-3.10/0100-mtd-split.patch b/target/linux/lantiq/patches-3.10/0100-mtd-split.patch
index 056f5177fa..1911b4451e 100644
--- a/target/linux/lantiq/patches-3.10/0100-mtd-split.patch
+++ b/target/linux/lantiq/patches-3.10/0100-mtd-split.patch
@@ -164,7 +164,7 @@
enum mtd_parser_type type,
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -616,7 +616,7 @@ out_register:
+@@ -615,7 +615,7 @@ out_register:
}
@@ -173,7 +173,7 @@
__mtd_add_partition(struct mtd_info *master, char *name,
long long offset, long long length, bool dup_check)
{
-@@ -737,7 +737,7 @@ run_parsers_by_type(struct mtd_part *sla
+@@ -736,7 +736,7 @@ run_parsers_by_type(struct mtd_part *sla
return nr_parts;
}
@@ -182,7 +182,7 @@
mtd_pad_erasesize(struct mtd_info *mtd, int offset, int len)
{
unsigned long mask = mtd->erasesize - 1;
-@@ -806,7 +806,6 @@ static void split_uimage(struct mtd_info
+@@ -805,7 +805,6 @@ static void split_uimage(struct mtd_info
return;
len = be32_to_cpu(hdr.size) + 0x40;