aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2016-06-24 16:50:54 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-24 16:50:54 +0200
commit59c662b6ece6da93cff729b9a2013fd7fa350675 (patch)
treeb5b99b6f210a7e83471054b62bfb6e3287c34608 /target/linux/lantiq
parent83f7442dccbe6773c62371a62da7fe1ca3104fd2 (diff)
downloadmaster-187ad058-59c662b6ece6da93cff729b9a2013fd7fa350675.tar.gz
master-187ad058-59c662b6ece6da93cff729b9a2013fd7fa350675.tar.bz2
master-187ad058-59c662b6ece6da93cff729b9a2013fd7fa350675.zip
lantiq: small fix for legacy profile builds
Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile43
1 files changed, 7 insertions, 36 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 91a3a36917..9f3c8ecba8 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -175,31 +175,6 @@ endif
endef
-define Image/InstallKernel/Template
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_KERNEL),)
- $(INSTALL_DIR) $(TARGET_DIR)/boot
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_UIMAGE),)
- $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage $(TARGET_DIR)/boot/
- ln -sf $(IMG_PREFIX)-$(1)-uImage $(TARGET_DIR)/boot/uImage
-endif
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_ZIMAGE),)
- $(CP) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-zImage $(TARGET_DIR)/boot/
- ln -sf $(IMG_PREFIX)-$(1)-zImage $(TARGET_DIR)/boot/zImage
-endif
-endif
-
-ifneq ($(CONFIG_TARGET_ROOTFS_INCLUDE_DTB),)
- $(INSTALL_DIR) $(TARGET_DIR)/boot
-
-ifneq ($(1),)
- $(CP) $(KDIR)/$(1).dtb $(TARGET_DIR)/boot/
-endif
-endif
-endef
-
define Image/BuildKernel/Template
$(call PatchKernelLzma,$(1))
$(call MkImageLzma,$(1))
@@ -220,7 +195,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
-define Image/Prepare/Profile
+define Image/Prepare/Kernel
$(call PatchKernelLzma,$(1))
$(call Image/BuildLoader/Template,$(1))
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
@@ -793,6 +768,12 @@ define Device/VGV7519BRN
endef
TARGET_DEVICES += VGV7519BRN
+define Image/Prepare
+ $(call Image/Prepare/Kernel,VG3503J)
+endef
+
+endif
+
define Image/Prepare/Profile
$(call Image/Build/Profile/$(1),loader)
endef
@@ -802,20 +783,10 @@ define Image/Build/Profile
$(call Image/Build/Profile/$(1),$(2))
endef
-define Image/Prepare
- $(call Image/Prepare/Profile,VG3503J)
-endef
-
-endif
-
define Image/BuildKernel
$(call Image/BuildKernel/Profile/$(PROFILE))
endef
-define Image/InstallKernel
- $(call Image/InstallKernel/Template/$(PROFILE))
-endef
-
define Image/Build
$(call Image/Build/Profile/$(PROFILE),$(1))
endef