aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-04-30 10:43:59 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-04-30 10:43:59 +0000
commit440bb56dc271acb58901c7d3fc7d4f6946e15868 (patch)
tree0c87ed8bd90f849befdf6f8932990e63d2c6dc9f /target/linux/lantiq
parent4c1da5becf0dd08b7a2019d7bbd677d8f06c9de9 (diff)
downloadmaster-187ad058-440bb56dc271acb58901c7d3fc7d4f6946e15868.tar.gz
master-187ad058-440bb56dc271acb58901c7d3fc7d4f6946e15868.tar.bz2
master-187ad058-440bb56dc271acb58901c7d3fc7d4f6946e15868.zip
kernel: update linux 3.8 to 3.8.10
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36493 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index 88f12b12c2..bcd0ff79fa 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs jffs2
SUBTARGETS=xway ase falcon
-LINUX_VERSION:=3.8.9
+LINUX_VERSION:=3.8.10
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
diff --git a/target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch b/target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch
index ee5fa73467..16da438183 100644
--- a/target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch
+++ b/target/linux/lantiq/patches-3.8/0041-owrt-mtd-split.patch
@@ -25,7 +25,7 @@ Subject: [PATCH 19/25] owrt mtd split
---help---
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -844,6 +844,168 @@ static int refresh_rootfs_split(struct m
+@@ -833,6 +833,168 @@ static int refresh_rootfs_split(struct m
}
#endif /* CONFIG_MTD_ROOTFS_SPLIT */
@@ -194,7 +194,7 @@ Subject: [PATCH 19/25] owrt mtd split
/*
* This function, given a master MTD object and a partition table, creates
* and registers slave MTD objects which are bound to the master according to
-@@ -860,7 +1022,7 @@ int add_mtd_partitions(struct mtd_info *
+@@ -849,7 +1011,7 @@ int add_mtd_partitions(struct mtd_info *
struct mtd_part *slave;
uint64_t cur_offset = 0;
int i;
@@ -203,7 +203,7 @@ Subject: [PATCH 19/25] owrt mtd split
int ret;
#endif
-@@ -877,6 +1039,15 @@ int add_mtd_partitions(struct mtd_info *
+@@ -866,6 +1028,15 @@ int add_mtd_partitions(struct mtd_info *
add_mtd_device(&slave->mtd);