aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-06-24 16:55:39 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2016-06-24 16:55:39 +0200
commit25407a7743722249883fd5463966288de98912ca (patch)
tree7c981335ecfc391af2c9e08684921a2e5635ead6 /target/linux/lantiq
parent2ae96f95d0300bcdf4006d80628ddb92193e9873 (diff)
downloadmaster-187ad058-25407a7743722249883fd5463966288de98912ca.tar.gz
master-187ad058-25407a7743722249883fd5463966288de98912ca.tar.bz2
master-187ad058-25407a7743722249883fd5463966288de98912ca.zip
lantiq: clean up / fix LegacyDevice template handling
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/image/Makefile22
1 files changed, 7 insertions, 15 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index e53fdd861e..d9424f8941 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -204,7 +204,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endef
endif
-define Image/Prepare/Kernel
+define Image/Prepare/Template
$(call PatchKernelLzma,$(1))
$(call Image/BuildLoader/Template,$(1))
$(Image/Prepare/InitramfsTemplate)
@@ -710,6 +710,7 @@ define LegacyDevice/FRITZ7360SL
endef
LEGACY_DEVICES += FRITZ7360L
+Image/Prepare/Profile/VG3503J=$(call Image/Prepare/Template,VG3503J)
Image/BuildKernel/Profile/VG3503J=$(call Image/BuildKernelLoader/Template,VG3503J)
Image/Build/Profile/VG3503J=$(call Image/BuildLoader/$(1),$(1),VG3503J)
@@ -768,27 +769,18 @@ define Device/VGV7519BRN
endef
TARGET_DEVICES += VGV7519BRN
-define Image/Prepare
- $(call Image/Prepare/Kernel,VG3503J)
-endef
-
endif
define Image/Prepare/Profile
- $(call Image/Build/Profile/$(1),loader)
-endef
-
-define Image/Build/Profile
- $(call Image/Build/Profile/$(1),buildkernel)
- $(call Image/Build/Profile/$(1),$(2))
+ $(call Image/Prepare/Profile/$(1))
endef
-define Image/BuildKernel
- $(call Image/BuildKernel/Profile/$(PROFILE))
+define Image/BuildKernel/Profile
+ $(call Image/BuildKernel/Profile/$(1))
endef
-define Image/Build
- $(call Image/Build/Profile/$(PROFILE),$(1))
+define Image/Build/Profile
+ $(call Image/Build/Profile/$(1),$(2))
endef
$(eval $(call BuildImage))