aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-01-29 18:29:45 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-01-29 18:29:45 +0000
commit046963da3aeea5ad7ba3ab583cd9a8b83b8cbf92 (patch)
tree4b5fe0aa08861c74d47f1e298255baba2be27a1a /target/linux/lantiq
parent37b7f67d00c2c143289c1d4a52515fc2cb1bf981 (diff)
downloadmaster-187ad058-046963da3aeea5ad7ba3ab583cd9a8b83b8cbf92.tar.gz
master-187ad058-046963da3aeea5ad7ba3ab583cd9a8b83b8cbf92.tar.bz2
master-187ad058-046963da3aeea5ad7ba3ab583cd9a8b83b8cbf92.zip
kernel: update linux 3.7 to 3.7.5
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35390 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq')
-rw-r--r--target/linux/lantiq/Makefile2
-rw-r--r--target/linux/lantiq/patches-3.7/0301-gptu.patch18
2 files changed, 7 insertions, 13 deletions
diff --git a/target/linux/lantiq/Makefile b/target/linux/lantiq/Makefile
index eb07e39d1f..febdeccfb4 100644
--- a/target/linux/lantiq/Makefile
+++ b/target/linux/lantiq/Makefile
@@ -11,7 +11,7 @@ BOARDNAME:=Lantiq GPON/XWAY/SVIP
FEATURES:=squashfs jffs2
SUBTARGETS=xway ase falcon
-LINUX_VERSION:=3.7.4
+LINUX_VERSION:=3.7.5
CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
diff --git a/target/linux/lantiq/patches-3.7/0301-gptu.patch b/target/linux/lantiq/patches-3.7/0301-gptu.patch
index 35ec060ecf..4ecf12f6fd 100644
--- a/target/linux/lantiq/patches-3.7/0301-gptu.patch
+++ b/target/linux/lantiq/patches-3.7/0301-gptu.patch
@@ -1,7 +1,5 @@
-Index: linux-3.7.4/arch/mips/lantiq/xway/timer.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.4/arch/mips/lantiq/xway/timer.c 2013-01-28 18:37:52.316180918 +0100
+--- /dev/null
++++ b/arch/mips/lantiq/xway/timer.c
@@ -0,0 +1,845 @@
+#ifndef CONFIG_SOC_AMAZON_SE
+
@@ -848,10 +846,8 @@ Index: linux-3.7.4/arch/mips/lantiq/xway/timer.c
+module_exit(lq_gptu_exit);
+
+#endif
-Index: linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h 2013-01-28 18:26:14.280164283 +0100
+--- /dev/null
++++ b/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
@@ -0,0 +1,155 @@
+#ifndef __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
+#define __DANUBE_GPTU_DEV_H__2005_07_26__10_19__
@@ -1008,10 +1004,8 @@ Index: linux-3.7.4/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
+ u32 reload, unsigned long arg1, unsigned long arg2);
+
+#endif /* __DANUBE_GPTU_DEV_H__2005_07_26__10_19__ */
-Index: linux-3.7.4/arch/mips/lantiq/xway/Makefile
-===================================================================
---- linux-3.7.4.orig/arch/mips/lantiq/xway/Makefile 2013-01-28 18:26:06.580164100 +0100
-+++ linux-3.7.4/arch/mips/lantiq/xway/Makefile 2013-01-28 18:38:07.848181285 +0100
+--- a/arch/mips/lantiq/xway/Makefile
++++ b/arch/mips/lantiq/xway/Makefile
@@ -1,3 +1,3 @@
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o