aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xway/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-04-11 19:18:07 +0000
committerJohn Crispin <blogic@openwrt.org>2013-04-11 19:18:07 +0000
commit0aa4ffad7adc8224f5a41fff8ca17b7050bd005f (patch)
treecfa5a679a307b3c34f96c59ca9881e4b2feef117 /target/linux/lantiq/xway/profiles
parent5bb33bd0cffb6305084227e82d03f73b40ecb3a4 (diff)
downloadmaster-187ad058-0aa4ffad7adc8224f5a41fff8ca17b7050bd005f.tar.gz
master-187ad058-0aa4ffad7adc8224f5a41fff8ca17b7050bd005f.tar.bz2
master-187ad058-0aa4ffad7adc8224f5a41fff8ca17b7050bd005f.zip
[lantiq] add VG3503J support
this adds basic support. the bootloader on these units is locked down. until we have a replacement we can do basic testing with these env variables in uboot. set update_openwrt erase 0xb0020000 0xb073ffff \;tftp 0x81000000 openwrt-lantiq-xway-VG3503J-squashfs.image\;cp.b 0x81000000 0xb0020000 \$(filesize) set bootcmd cp.b 0xb0020000 0x80002000 0x400000\; go 0x80002000 unfortunatley the bootloader ignores the bootcmd, so autobooting is not possible yet. you need to call "run bootcmd" by hand after each power cycle. please note that the vdsl firmware is non redistributable. you can find it in the GPL drop that BT provides. Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36315 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/xway/profiles')
-rw-r--r--target/linux/lantiq/xway/profiles/arv.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/lantiq/xway/profiles/arv.mk b/target/linux/lantiq/xway/profiles/arv.mk
index a4f11ca238..21311882a7 100644
--- a/target/linux/lantiq/xway/profiles/arv.mk
+++ b/target/linux/lantiq/xway/profiles/arv.mk
@@ -114,3 +114,11 @@ define Profile/ARV752DPW22
endef
$(eval $(call Profile,ARV752DPW22))
+
+define Profile/VG3503J
+ NAME:=BT Openreach - ECI VDSL Modem
+ PACKAGES:=kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-ptm-vr9 ltq-vdsl-app
+endef
+
+$(eval $(call Profile,VG3503J))