aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-07-07 13:44:53 +0000
committerJohn Crispin <blogic@openwrt.org>2015-07-07 13:44:53 +0000
commitfc39bcee344c920d5a017dbfbc408e12591fc848 (patch)
treea85d92c1e729ca1c5fbbcd21b6db3ed54cb3efd2 /target/linux/lantiq/xrx200/profiles
parent0064125580f2936569c8fc3248676a10df5f9851 (diff)
downloadmaster-187ad058-fc39bcee344c920d5a017dbfbc408e12591fc848.tar.gz
master-187ad058-fc39bcee344c920d5a017dbfbc408e12591fc848.tar.bz2
master-187ad058-fc39bcee344c920d5a017dbfbc408e12591fc848.zip
lantiq: Add support for the BT Home Hub 5A
u-boot support depends on the next "upstream" version ([0]) from Daniel Schwierzeck. Since the installation process is quite complicated a "how to" was added to the wiki: [1] [0] https://github.com/danielschwierzeck/u-boot-lantiq/tree/openwrt/v2014.01-next [1] http://wiki.openwrt.org/toh/bt/homehub_v5a V2: Use the correct PCI interrupt (fixes 2.4GHz wifi) Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46223 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/xrx200/profiles')
-rw-r--r--target/linux/lantiq/xrx200/profiles/bt.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/lantiq/xrx200/profiles/bt.mk b/target/linux/lantiq/xrx200/profiles/bt.mk
new file mode 100644
index 0000000000..a1083bbb6d
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/bt.mk
@@ -0,0 +1,9 @@
+define Profile/BTHOMEHUBV5A
+ NAME:=BT Home Hub 5A
+ PACKAGES:=kmod-ath9k kmod-ath10k wpad-mini kmod-usb-dwc2
+endef
+
+BTHOMEHUBV5A_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+BTHOMEHUBV5A_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,BTHOMEHUBV5A))