aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/xrx200/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2014-03-30 09:16:06 +0000
committerJohn Crispin <blogic@openwrt.org>2014-03-30 09:16:06 +0000
commit4a3d655e10c04e166bcafd34c34365ee46fa2d31 (patch)
tree586217c67fc2cf28506b928862ab75cb2a0b14cd /target/linux/lantiq/xrx200/profiles
parent8f230ce46475e7e11e81a188e7b14f963f4c26bb (diff)
downloadmaster-187ad058-4a3d655e10c04e166bcafd34c34365ee46fa2d31.tar.gz
master-187ad058-4a3d655e10c04e166bcafd34c34365ee46fa2d31.tar.bz2
master-187ad058-4a3d655e10c04e166bcafd34c34365ee46fa2d31.zip
lantiq: add support for ZyXEL P2812HNUFX
This patch adds almost full support for this board. WiFi is still not working. The FXS ports are not functional due to missing support for the TAPI driver on VR9 SoC. Signed-off-by: Antonios Vamporakis <ant@area128.com> Tested-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40317 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/xrx200/profiles')
-rw-r--r--target/linux/lantiq/xrx200/profiles/zyxel.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/lantiq/xrx200/profiles/zyxel.mk b/target/linux/lantiq/xrx200/profiles/zyxel.mk
new file mode 100644
index 0000000000..e758a50360
--- /dev/null
+++ b/target/linux/lantiq/xrx200/profiles/zyxel.mk
@@ -0,0 +1,14 @@
+define Profile/P2812HNUFX
+ NAME:=ZyXEL P-2812HNU-Fx
+ PACKAGES:=kmod-rt2800-pci wpad-mini \
+ kmod-ltq-deu-vr9 kmod-ltq-hcd-vr9 \
+ kmod-ltq-vdsl-vr9-mei kmod-ltq-vdsl-vr9 \
+ kmod-ltq-atm-vr9 ltq-vdsl-vr9-fw-installer \
+ ltq-vdsl-app ppp-mod-pppoa \
+ swconfig
+endef
+
+P2812HNUFX_UBIFS_OPTS:="-m 2048 -e 126KiB -c 4096"
+P2812HNUFX_UBI_OPTS:="-m 2048 -p 128KiB -s 512"
+
+$(eval $(call Profile,P2812HNUFX))