aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/lantiq/svip_be/profiles
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2012-07-31 18:49:54 +0000
committerJohn Crispin <blogic@openwrt.org>2012-07-31 18:49:54 +0000
commitf3513b1b9bacde9a6572a98c168b6423e500f5d2 (patch)
tree4035b1c30da5aa080517ab0846ff78de8d3825d5 /target/linux/lantiq/svip_be/profiles
parent9f30da9d337f5de6976c42c7ed413d9efa2efe90 (diff)
downloadmaster-187ad058-f3513b1b9bacde9a6572a98c168b6423e500f5d2.tar.gz
master-187ad058-f3513b1b9bacde9a6572a98c168b6423e500f5d2.tar.bz2
master-187ad058-f3513b1b9bacde9a6572a98c168b6423e500f5d2.zip
[lantiq] add lantiq svip support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32925 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/lantiq/svip_be/profiles')
-rw-r--r--target/linux/lantiq/svip_be/profiles/000-generic.mk8
-rw-r--r--target/linux/lantiq/svip_be/profiles/001-lantiq.mk25
2 files changed, 33 insertions, 0 deletions
diff --git a/target/linux/lantiq/svip_be/profiles/000-generic.mk b/target/linux/lantiq/svip_be/profiles/000-generic.mk
new file mode 100644
index 0000000000..731e4fce5a
--- /dev/null
+++ b/target/linux/lantiq/svip_be/profiles/000-generic.mk
@@ -0,0 +1,8 @@
+define Profile/Generic
+ NAME:=Generic - all boards
+ PACKAGES:=
+endef
+
+$(eval $(call Profile,Generic))
+
+
diff --git a/target/linux/lantiq/svip_be/profiles/001-lantiq.mk b/target/linux/lantiq/svip_be/profiles/001-lantiq.mk
new file mode 100644
index 0000000000..5503790aff
--- /dev/null
+++ b/target/linux/lantiq/svip_be/profiles/001-lantiq.mk
@@ -0,0 +1,25 @@
+define Profile/EASY336
+ NAME:=EASY336
+ PACKAGES:=
+endef
+
+define Profile/EASY336/Description
+ Lantiq EASY336 evalkit
+endef
+
+$(eval $(call Profile,EASY336))
+
+define Profile/EASY33016
+ NAME:=EASY33016
+ PACKAGES:= \
+ kmod-ifxos ifx-vos ifx-evtlog svip-switch \
+ voice-lib-tapi voice-lib-cli voice-tapi-cli \
+ voice-tapi voice-tapidemo-xt voice-vatests voice-vxt voice-xtbox
+endef
+
+define Profile/EASY33016/Description
+ Lantiq EASY33016 evalkit
+endef
+
+$(eval $(call Profile,EASY33016))
+